ITV player is not working correctly- blank programmes

13

Comments

  • SanjSanj Posts: 1,644Member ✭✭✭✭✭
    edited 21 December 2016, 7:57PM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Sorry to hear that LGX. A couple of questions for you:
    • Is there anything else on screen, like a loading sign in the corner or any error messages?
    • Are you able to close the player at that time and go back into YouView?
    • Is this happening on all programmes you've tried or just an individual one, if the latter, can you let us know which programme?
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    This issue has now been fixed through an ITV Player update.

    Hello Sanj

    The issue that is the subject of this thread has not been fixed by this update. The problem persists.
  • stormystormy Posts: 1,011Member ✭✭
    edited 1 December 2016, 9:24AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    I too an getting this *sigh* just trying to watch Dinosaur Britain episode one. Same issue. Adverts load and play but the programme never starts.
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    A particularly entertaining feature, second only to the programme not starting, is getting a blank screen for a while after the first part of a show and then having to sit through the same advert twice. Or sometimes two sets of adverts in succession.

    It is easily possible to spend a whole evening trying to watch a half-hour show.

    On-Demand? More like Excuse me, have you got a minute?
  • SanjSanj Posts: 1,644Member ✭✭✭✭✭
    edited 21 December 2016, 7:57PM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Hi Jonesh / stormy - The issue resolved through the ITV Player update was for when you tried to access the view 'All Episodes' option but it wouldn't work as LGX was experiencing. 

    Any other issues please let us know and we'll look into them. Stormy thanks for the example, we can have a look at that and get back to you. 

    Jonesh - Can you give a description of the issue you are experiencing please?
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Hello Sanj

    The main issue is the ITV Player On-Demand programme not starting. Just the rotating circle in the top-right of the screen that eventually disappears leaving a blank screen. Cancelling, going back to the main ITV Player menu and re-starting the programme usually nudges it into action, but there is always a long pause before the adverts start.

    Even when the adverts do eventually start, often the same advert is repeated twice and sometimes there are two sets of adverts. Then another long pause before the programme starts. There are always long pauses between the programme and the adverts and vice versa.

    The problem seems to be worse on recently transmitted popular progammes - eg, Emmerdale. Episodes that are more than a few days old seem to work more or less OK.

    Accessing the programme through the Player seems to work a bit better that using the Guide. Still problematic though.

    I contacted the ITV Player help people and one of the questions that I was asked was "is there a dial tone on my telephone". I understand why they asked it, but I gave up with them after that.
  • stormystormy Posts: 1,011Member ✭✭
    edited 1 December 2016, 9:24AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Thanks Sanj, let me know please. Would like to access that episode if possible, only episode 2 works at the moment.
  • SanjSanj Posts: 1,644Member ✭✭✭✭✭
    edited 21 December 2016, 7:57PM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Hi Stormy - We've had a look into this and this has been identified as an issue we are aware of and is currently being investigated by ITV. 

    Thanks for feeding back, I will update you when we know more.
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Hello Sanj.

    I am probably wasting my time again, but my reply to your question above is at least the third time on this forum that I have taken time to describe the issues that I experience with the ITV Player.

    Some time ago I started a thread about the problems here: https://community.youview.com/youview/topics/problems-with-itvplayer

    There were no replies, other than one from me.

    I have also contacted ITV Player support about the problems. Many emails were exchanged and eventually they said that if the problems persist I should contact YouView. First off they blamed my YouView box, then my network setup, and then YouView. They told me to contact YouView on 0845 099 2910 if the problems persisted. They do.

    Maybe I am getting paranoid, but I feel that I am being ignored. You asked me a question and I answered it as fully as I could, but you have not responded.

    I have spent a lot of time trying to flag up the problems that we experience with the ITV Player and I am starting to understand why there are so many postings on this forum from people who say that they are so frustrated with unresolved issues with YouView that they want to ditch their box.

    The GetSatisfaction software playing up doesn't help matters either.
  • SanjSanj Posts: 1,644Member ✭✭✭✭✭
    edited 21 December 2016, 7:57PM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Hi Jonesh - I don't want you to feel as though you are being ignored. My apologies if it has come across that way. 

    Regarding your post 3 months ago, issues like that are usually content related and from your follow up post, we were under the impression that issue had resolved itself which may have been a misinterpretation.

    In this instance, some research was being done my end before responding as there are a few considerations with your issues. I'll get back to you later today with some follow up questions which will hopefully bring us closer to resolving this for you. 
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    I appreciate your response Sanj. Thank you.

    I did quite a lot of work on this problem for the ITV Player help team, so hopefully some of my findings might be useful to you. They would not admit to the slightest possibility that the problem could be at their end and as I said above, they suggested that I should contact YouView. They even gave me the number to use. I didn't use it because I thought that I would be more likely to get a result by posting on this forum.
  • SanjSanj Posts: 1,644Member ✭✭✭✭✭
    edited 21 December 2016, 7:57PM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Hi Jonesh - Thanks for your patience. Can you let me know:
    • Box Make/Model
    • Software Versions
    • Broadband Line Provider
    • Broadband Speed
    • Method of connection (Powerline adapter or direct ethernet cable)
    • Examples of programmes affected in the past 7 days.
    • ITV Player version (press help in the player)
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Hello Sanj. Thank you for your comment.
    • The box is a BT supplied Humax DTR T1000
    • Manufacturers Software:                  21.50.40
    • Component Software:                         2. 9.34
    • Platform Configuration:                          1393
    • ISP Configuration:                                    203 
    • Broadband line supplier:                            BT
    • Broadband speed, measured on a computed attached to the same network switch as the YouView box:                    72/73Mbps
    • The network connection of the YouView box is by ethernet cable via a network switch which is attached to the router using a cable
    • We only use the ITV Player to watch Emmerdale
    • The ITV Player version is:    1.6.3.92bc45fa28
    The ITV Player has several tricks up its sleeve. I won't bore you with all of them, but yesterday evening was typical:

    I accessed yesterday evenings Emmerdale by loading the Player first as that seems to be rather less problematic than using the Guide. There was a pause of probably a couple of minutes before the first adverts started. They lasted for three or four minutes and then there was a pause before the programme started.

    It was a hour long episode and we had watched the first two of the four sections earlier as it was broadcast, so I fast-forwarded to the second set of adverts, not counting the ones at the start.

    It then made us sit through two sets of adverts which lasted probably six or eight minutes. Some of the adverts were repeated. it then jumped to the main menu and asking if we wanted to watch the programme again. It didn't give us the opportunity to watch the actual programme.

    OK, I'm a glutton for punishment, probably by watching Emmerdale in the first place, but I tried again and got the same result. I then gave up and we watched something else

    After I saw your post this morning, I did an eight second "Hello" reset of the box and tried again. Exactly the same thing happened - no show.

    I know that I could record the programmed and miss out the adverts, but I only use workarounds as a last resort.

    The fact is that the ITV Player doesn't work for us and it hasn't done for months.
  • SanjSanj Posts: 1,644Member ✭✭✭✭✭
    edited 21 December 2016, 7:57PM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Hi Jonesh - Thank you for your detailed description. Having looked into it, we know this is an issue that is currently being investigated by BT and ITV. We've passed your feedback along and if we have any additional information we'll let you know. 
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Thanks Sanj

    The jumping to the end of the programme and forcing you to start again is a relatively new problem.

    The main problems have been:
    • A long delay before the first set of adverts
    • Another long delay between the adverts and the show starting
    • Long delays between the show and the adverts at each advert break
    • Two consecutive sets of adverts
    • The same advert repeated
    • No adverts at all! - just a time gap where the adverts should be
    Incidentally, to avoid all the hassle I have set to record this evening's episode - on a Topfield.
  • Old Welsh DragonOld Welsh Dragon Posts: 367Member
    edited 11 December 2016, 11:58AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Had problems with ITV player last night, as posted above. Also sudden ads 20 seconds or so in to emmerdale then it refused to play ads only. Ended up watch ITV player on my Samsung tv.

    BT G4 box with latest software.
    BT infinity 1
    Broadband speed around 37Mbps
    Ethernet cable wired connection.
  • VisionmanVisionman Posts: 8,883Member ✭✭✭
    edited 22 December 2016, 12:06AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    For test purposes I accessed the ITV player as well. I don't believe ones set up matters. Same results. This player is, in short, pathetic. But as said above they know about it.
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    It's good to know that I am not the only person having problems with the ITV Player.

    I was starting to think that it was my punishment for watching Emmerdale!
  • VisionmanVisionman Posts: 8,883Member ✭✭✭
    edited 22 December 2016, 12:06AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Oh it was that as well. :)
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Probably.

    We just finished watching the recording of tonight's Emmerdale on the Topfield. It was good to be able to skip the adverts.

    I used to joke about my parents recording Coronation Street on their VCR to watch it later. Now I am doing the same thing. Well not exactly, but you know what I mean.
  • SanjSanj Posts: 1,644Member ✭✭✭✭✭
    edited 21 December 2016, 7:56PM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Hi Visionman - IIRC you have a BT line too?
  • VisionmanVisionman Posts: 8,883Member ✭✭✭
    edited 22 December 2016, 12:06AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Yes thats right, but please don't pursue this on my behalf, I don't watch the ITV player. I record everything that catches my eye.
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Ignore VM Sanj. We are all in this together. :)
  • stormystormy Posts: 1,011Member ✭✭
    edited 1 December 2016, 9:24AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    Must admit I try and avoid ITV player now, its too hit and miss as to if it actually works and shows the desired programme.
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM

    Further to blank programme: switching off subtitles made it work without reset or other faffing about. The programme in question was a 4 day old episode of emmerdale. Needed mid afternoon. As the humax didn't work straight away it was watched on a tablet. While being watched the humax would not play any of the three different itv programmes I tried. Subtitles off, humax itvplayer played straight away, while it was still being watched on the tablet. (60 Mbps fttc).

    We've given up on it as well. It is far too unreliable. We do what Visionman does and record stuff that we want to watch. It has the advantage of being able to skip the adverts. For that reason alone you would think that they would get it fixed.
  • Philip TrottPhilip Trott Posts: 1,040Administrator admin
    edited 6 March 2017, 7:40PM
    Hi guys,

    We believe the issue some have had with programmes not playing back on the ITV player is now fixed. Programmes should correctly play following the adverts without any problems.

    If anyone experiences playback issues on the ITV player please let us know the programme, episode number and a description of the problem and we will investigate this further with ITV.

    Thanks,

    Phil
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM
    Phil8 said:

    Hi guys,

    We believe the issue some have had with programmes not playing back on the ITV player is now fixed. Programmes should correctly play following the adverts without any problems.

    If anyone experiences playback issues on the ITV player please let us know the programme, episode number and a description of the problem and we will investigate this further with ITV.

    Thanks,

    Phil

    I just gave it a try on last night's (Wednesday, 17/09/2015) Emmerdale. There were no adverts at the beginning, but it took about a minute and a half (I timed it) between pressing OK and the programme starting.

    It wasn't a real test, because I didn't want to watch it. I fast-forwarded to the first set of adverts and pressed play. It wouldn't re-start, so I gave up.

    It looks like nothing has changed, but I will try again later with tonight's show.

    I did a player update, but the version that I have got is still  1.6.3.92bc45fa28.

    it looks like "fa" is the most significant part of that version. :-)
  • VisionmanVisionman Posts: 8,883Member ✭✭✭
    edited 22 December 2016, 12:06AM
    Phil8 said:

    Hi guys,

    We believe the issue some have had with programmes not playing back on the ITV player is now fixed. Programmes should correctly play following the adverts without any problems.

    If anyone experiences playback issues on the ITV player please let us know the programme, episode number and a description of the problem and we will investigate this further with ITV.

    Thanks,

    Phil

    For test purposes, I've just accessed the ITV player (Parking Wars) and it played perfectly from start to finish. Will wonders never cease. :)

    Its the same version as jonesh - 1.6.3.92bc45fa28.
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM
    Phil8 said:

    Hi guys,

    We believe the issue some have had with programmes not playing back on the ITV player is now fixed. Programmes should correctly play following the adverts without any problems.

    If anyone experiences playback issues on the ITV player please let us know the programme, episode number and a description of the problem and we will investigate this further with ITV.

    Thanks,

    Phil

    It's your reward for not watching Emmerdale!
  • joneshjonesh Posts: 1,187Member ✭✭✭
    edited 21 December 2016, 12:03AM
    Phil8 said:

    Hi guys,

    We believe the issue some have had with programmes not playing back on the ITV player is now fixed. Programmes should correctly play following the adverts without any problems.

    If anyone experiences playback issues on the ITV player please let us know the programme, episode number and a description of the problem and we will investigate this further with ITV.

    Thanks,

    Phil

    I just watched tonight's Emmerdale on the ITV Player.

    There was a pause of about 30 seconds before the programme started. Not that I want them, but there were no adverts at the beginning. The first part played OK, then just one set of adverts - not two sets, as previously.

    The second part started after the adverts without much of a pause. It played OK until I tried to skip to the third section. After a pause we got adverts, then it jumped to the last (fourth) part of the show, missing out the third part.

    It let me skip (fastwind) back to the third part, which played OK. Then a brief pause with no adverts, before the fourth part of the show.

    It was useable. Overall, a huge improvement.

    With the exception of the pause at the beginning before the show started, I think that it would have played as it should if I hadn't tried to skip sections,

    I don't use it very often, but when I do I will report back on how it goes .
Sign In or Register to comment.