SCART Pin 8 'hot' in low Eco Standby - bug

RoyRoy Posts: 15,208Member ✭✭✭
edited 6 March 2017, 10:48PM in Archived Posts
Marie wants to report the bug whereby turning on our Samsung TV when the YouView box is connected via SCART always brings up the TV in 'Ext' mode, instead of showing the broadcast channel, as it should.

This has been observed since testing the new 17.3 functionality of being able to have both SCART and HDMI connected at once. Though it may have been present earlier; we haven't connected via SCART before.

It is no biggie for us, as this was just a testing stage, and disconnecting the SCART restores the normal TV default of starting up in broadcast when the YouView box is in standby. But it might be an issue for users regularly connecting this way.

Wikipedia suggests the issue results from pin 8 of the SCART being erroneously held high at 5v or more (or at least, higher than 2v, the behaviour between 2 and 5v being undefined), when it should be no more than 0-2v, to indicate Off.

Our YouView box is a retail Humax DTR-T1000, running in Low Eco mode. I do not know what the behaviour might be in High Eco mode, and I do not intend to delete my connected devices in order to find out, but one of us better placed for this might like to give it a try.

This issue may be connected to the known bug (unless it has been silently fixed without us being told) that the YouView HDMI output stays 'hot' in Standby, though this issue fortunately does not cause our TV to come on in HDMI instead of broadcast TV.
This is not the YouView that I knew  :'(
«1

Comments

  • JezzaJezza Posts: 22Member
    edited 6 March 2017, 10:48PM
    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    Thanks Jezza, that would indeed solve the immediate problem.

    But should I change the YouView box, the TV, or every SCART cable I own? :-)

    And should everybody else? :-)

    Or should YouView/Humax fix their bug, in one place, centrally, and roll the change out to us?


    This is not the YouView that I knew  :'(
  • JezzaJezza Posts: 22Member
    edited 24 September 2014, 8:13PM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    No!

    Also your problem isn't a bug.

    Hope I've helped if not do come back to me.







  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    Thanks Jezza, and here I am.

    Reviewing my original posting, I may not have made it clear enough in the body of the posting that this is happening even when the YouView box is in standby, though I have said that in the thread title :-(

    As it happens in standby I really think it's a bug, and with that clarification, perhaps you would now think so too.

    But if not, I would be very grateful if you would explain to me how and why it isn't.
    This is not the YouView that I knew  :'(
  • JezzaJezza Posts: 22Member
    edited 24 September 2014, 8:13PM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    I have a Samsung TV connected by scart to a DVD player. If I turn TV on all is fine but as soon as I turn on the player the TV automatically switches to it unless of course I disable Pin 8. I live with it because that's the way a fully connected scart works

    This problem is not that common these days as more people are wholly using HDMI leads.

    On my main TV  the  YouView Box is connected HDMI but it is also connected by scart to a DVD recorder. This scart is not enabled and switching to YouView until I switch TV to that scart input.

    I hope this helps.

  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    Hi Jezza

    Bit missing from your description there, I think.

    SCART from YouView to DVD recorder, but you talk about switching TV to that SCART input. I think you probably have a further SCART cable from DVD recorder to TV, and that is what you are talking about?

    Though it might be a SCART splitter, or some other such thing - please clarify.

    But I'm glad you've got a Samsung TV as so have I, and that's one less difference to worry about, perhaps.

    So the interesting question is; if your DVD recorder is in standby, and you turn your TV on intending to watch broadcast programmes, does the DVD recorder grab the TV onto its input and you have to switch away from it?

    And if so, does this behaviour cease when you disconnect that SCART from the TV? (Just to ensure the TV is defaulting to broadcast when it should, as you can set modern Samsungs to default to an Ext input instead of broadcast, though ours is set for broadcast).

    This is not the YouView that I knew  :'(
  • JezzaJezza Posts: 22Member
    edited 24 September 2014, 8:13PM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    Hi Roy,

    Sorry for delay in replying - didn't get usual notification of your post.

    I have a Scart lead from the YouView Box to the Scart input of DVD recorder and then connect a second Scart lead to the Scart ouput of the recorder and finally to the Scart input of the TV.

    The Scart is only enabled if I bring the Recorder out of standby and use it to record to DVD a program on the YouView Box but I can then switch TV to broadcast while this is going on and it will not default back to the TV Scart input.

    Also the TV does not default from broadcast programs to the DVD recorder when it is in standby and the TV is first turned on.

    I do hope I've explained myself ok!

  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    Hi Jezza

    Yes, everything you describe is the behaviour I would expect.

    But now imagine that the TV did default from broadcast programmes to the DVD recorder when it is in standby and the TV is first turned on.

    Wouldn't that be annoying? And wouldn't it be wrong behaviour? A bug in fact?

    Because if you substitute 'YouView box' for 'DVD recorder' in the above, that's exactly what ours does do.

    As you have the SCART cable, and the setup you need, you might even want to try it for yourself as a test - just take the first SCART cable out of the DVD player and the second one out of the TV and plug the first SCART into the TV, thus connecting the YouView box directly to the TV.

    See if it does what I described. See if you still think that it's not a bug.

    Happy bug hunting!
    This is not the YouView that I knew  :'(
  • JezzaJezza Posts: 22Member
    edited 24 September 2014, 8:13PM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    Hi Roy,

    I'm wondering whether your Scart lead may be at fault. Have you tried a brand new fully connected lead of a different make from the ones you have at present?- I use Profigold.

    Also have you tried snipping pin 8 on the Scart lead to see if this action solves your problem?

    Finally I can confirm that I don't experience the problem you are having with my YouView box which is connected directly by the Scart lead to the TV.

  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    SCART is fine, thank you. Also borrowed the SCART off my legacy DVD player, which does not exhibit this issue with the (different) TV that is connected to, and get exactly the same result,

    As I said I am absolutely not interested in crippling any SCART leads I own to get round a YouView bug.

    As regards your last paragraph, you don't have your YouView box directly connected to your TV. The connection is via your DVD recorder, which restores some sanity to the proceedings.

    Or are you saying you have tried the real direct connection I describe above?

    If not, please do this soonest, so the YouView Reps haven't got an excuse to sit back and do nothing until I finally convince you this is a bug.

    (Though I'm sure that Phil or someone working for him could pretty easily try this out on a test Humax at YouView Towers, and confirm, or not, my observation and my diagnosis. How about it?)
    This is not the YouView that I knew  :'(
  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 6 March 2017, 10:48PM
    Now that I have finally convinced Jezza that this is indeed a bug (or at least, now that he has given up trying to convince me that it isn't) can I please have some acknowledgement from YouView staffers that this is indeed an issue that should be taken on board?

    It is at least as dangerous for Marie to be ignored as it was for Alex Forrest to be; possibly more so :-)
    This is not the YouView that I knew  :'(
  • Eric KnowlesEric Knowles Posts: 4Member
    edited 23 February 2014, 11:23PM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    I have it stops it switching but makes it even more annoying as you then have to fiddle about with the TV remote when you want to switch to it.
  • Philip TrottPhilip Trott Posts: 1,040Administrator admin
    edited 17 February 2017, 5:59PM
    Hi Roy, I would just like to clarify before querying this further. You have two TVs, one with HDMI and the other with SCART coming from the same YouView box going into two different TVs.

    You observe that when turning the box on, HDMI goes to the correct channels but on SCART the channel is defaulting to Ext and not the correct channel?

    Phil
  • JezzaJezza Posts: 22Member
    edited 24 September 2014, 8:13PM
    Roy1 said:

    Now that I have finally convinced Jezza that this is indeed a bug (or at least, now that he has given up trying to convince me that it isn't) can I please have some acknowledgement from YouView staffers that this is indeed an issue that should be taken on board?

    It is at least as dangerous for Marie to be ignored as it was for Alex Forrest to be; possibly more so :-)

    Hi Roy,

    I thought these two posts from the BT Forum posted today might be of interest to you and others on the YouView Forum :-

    A BT Forum member wrote:-

    Just out of interest is there any reason why the last update (15.11) was rolled out to everyone in 4 days and yet this one is scheduled to take weeks...
    Hi
    For the Humax box, we've had a later version come into test earlier than expected and feel the additional fixes, applicable to certain customer situations, justifies holding the rollout until this new version launches next month.

     Sorry about that - BT TV Expert I am a BT Employee and an expert on TV queries. I am here to give advice primarily on the BT Vision+ box

     

    on ‎24-02-2014 20h00                    
             from what I'm hearing,don't expect 17.3 imminently. I'll keep you all updated when I hear more.

    I am a BT Employee and an expert on TV queries. I am here to give advice primarily on the BT Vision+ box"




  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    Hi Eric

    Have what, exactly? What you say isn't entirely clear to me....
    This is not the YouView that I knew  :'(
  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Roy1 said:

    Now that I have finally convinced Jezza that this is indeed a bug (or at least, now that he has given up trying to convince me that it isn't) can I please have some acknowledgement from YouView staffers that this is indeed an issue that should be taken on board?

    It is at least as dangerous for Marie to be ignored as it was for Alex Forrest to be; possibly more so :-)

    Hi Jezza

    I have a retail YouView box, not a BT one. Is there some relevance here I am missing, though?
    This is not the YouView that I knew  :'(
  • Eric KnowlesEric Knowles Posts: 4Member
    edited 25 February 2014, 9:58AM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    Tried disconecting pin 8.
  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 6 March 2017, 10:48PM
    Hi Phil

    Thanks for looking at this.

    I actually had the SCART and the HDMI on the same TV (long story, but not relevant to the issue, as disconnecting the HDMI ruled out any interaction from that).

    Switching on my TV with either nothing connected or only HDMI connected, and the YouView box in standby, it goes to the broadcast channels, which is what we desire.

    But switching off the TV again, disconnecting the HDMI if present, plugging in the SCART from the YouView box in standby, and then switching on the TV, it goes to Ext, the input the SCART is on, instead of broadcast, and of course shows just a blank screen, as there is no signal from the YouView box in standby.

    I think this is happening because the YouView box in standby (Low Eco standby, FWIW) is holding pin 8 high, when it should only hold this pin high when it is On.

    But I might be wrong about the actual cause here; I'll leave that for you to determine, as long as you can reproduce the problem, and as long as you agree with me that when the YouView box is in standby, its SCART output should not be grabbing the TV.

    Regards

    Roy
    This is not the YouView that I knew  :'(
  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Jezza said:

    Have you tried disconnecting pin 8 of the scart plugs to stop the auto switching?

    Just a thought.

    Ah, got it, thanks Eric.

    Yes, disconnecting that pin means the function won't work when you do want it to, such as when the YouView box is actually switched on.

    Hence my unbending stance that this problem should be addressed by a YouView bug fix, and not a pair of wire snippers :-)
    This is not the YouView that I knew  :'(
  • JezzaJezza Posts: 22Member
    edited 24 September 2014, 8:13PM
    Roy1 said:

    Now that I have finally convinced Jezza that this is indeed a bug (or at least, now that he has given up trying to convince me that it isn't) can I please have some acknowledgement from YouView staffers that this is indeed an issue that should be taken on board?

    It is at least as dangerous for Marie to be ignored as it was for Alex Forrest to be; possibly more so :-)


    Hi Roy,

    What I'm trying to say is that the updates the retail boxes have received so far may not have been as thoroughly tested as those of BT before release and perhaps that is why retail customers are experiencing so many problems.

    Just a thought.


  • Philip TrottPhilip Trott Posts: 1,040Administrator admin
    edited 6 March 2017, 10:48PM
    Hi Roy, this may be TV specific as we have tried to recreate the issue here but haven't been able to. When connected with the SCART cable in standby the TV defaulted to the broadcast channel for the TV.

  • Eric KnowlesEric Knowles Posts: 4Member
    edited 25 February 2014, 1:19PM
    Some TVs default to scart some don't some you can set to scart priority in the menu like mine.
  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Phil8 said:

    Hi Roy, this may be TV specific as we have tried to recreate the issue here but haven't been able to. When connected with the SCART cable in standby the TV defaulted to the broadcast channel for the TV.

    Thanks Phil

    Yes, TV sets are different, as Eric says, and I can set my 2013 Samsung to default to Ext or broadcast as I wish; but I don't seem to have this setting on the 2011 Samsung UE32D6530 that I am having the issue with.

    I can try one or two other SCART devices I have at home, when I return in late April, and see if the mere fact of having something plugged into the SCART socket makes the TV default to this.

    But I was kind of hoping that instead of just trying the YouView box on a TV you had there that you would actually test the pinout on 8, to see if it was in spec or not on a YouView box in Low Eco standby.

    I could do this myself, at a pinch, but it would be much easier with the sort of SCART breakout box that I hope you possess.

    Could you bear to try this?

    Thanks

    Roy
    This is not the YouView that I knew  :'(
  • Eric KnowlesEric Knowles Posts: 4Member
    edited 25 February 2014, 11:31PM
    Phil8 said:

    Hi Roy, this may be TV specific as we have tried to recreate the issue here but haven't been able to. When connected with the SCART cable in standby the TV defaulted to the broadcast channel for the TV.

    I have tested my YouView with a break out box the only way to get the 5v off pin 8 is to switch the mains off to the box.
  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Roy1 said:

    Now that I have finally convinced Jezza that this is indeed a bug (or at least, now that he has given up trying to convince me that it isn't) can I please have some acknowledgement from YouView staffers that this is indeed an issue that should be taken on board?

    It is at least as dangerous for Marie to be ignored as it was for Alex Forrest to be; possibly more so :-)

    OK, thanks. I think BT are talking about not having yet rolled out the 17.3.0 functionality, which they will need to knit in to their existing extended YouView OS, whereas we retail customers do have it already.

    But I am equally sure that whether BT find anything YouView have missed or not, 17.3.0 will bring new issues as well as fixes.

    But as I said at the beginning, I don't know how long-standing my SCART issue has been, because I never used SCART before with YouView. So whether it arrived with 17.3.0, or was there before, or is even an issue with the TV, as YouView have suggested it might be, I don't know.

    I can test the 'issue with the TV' suggestion only when I am back in the UK; but then the YouView box is currently sending its SCART out only to my Slingbox, which does not appear to have an on/off switch anyway, to hurl my YouView capability clear across the Bay of Biscay, and most of mainland Spain, where it is caught by an iPod Touch, thrown to an Apple TV box, and finally appears on a TV here, with picture quality better than we were getting from Sky.

    (Though I realise I'm quite on my own if anything goes wrong with this multi-ISP, multi-make, Heath Robinson chain of devices :-) )
    This is not the YouView that I knew  :'(
  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:39AM
    Phil8 said:

    Hi Roy, this may be TV specific as we have tried to recreate the issue here but haven't been able to. When connected with the SCART cable in standby the TV defaulted to the broadcast channel for the TV.

    Thanks, Eric.

    That would very much imply that despite YouView testing for this issue with a TV in their lab, they were using one of those TVs that is able to make its own decision to ignore the high pin 8, and not that the pin 8 is OK.

    YouView, can you repeat your test with a dumber TV, perhaps, one without a menu option to select the default input; and/or just agree with Eric's findings that a YouView box in standby does hold pin 8 high, and my assertion that it shouldn't, and put this on your fix list (or possibly Humax's, depending on who controls this aspect of things?)
    This is not the YouView that I knew  :'(
  • SanjSanj Posts: 1,644Member ✭✭✭✭✭
    edited 6 March 2017, 10:48PM
    Hi Roy - This issue was reproduced by our test team and is being looked into.
  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:40AM
    Sanj said:

    Hi Roy - This issue was reproduced by our test team and is being looked into.

    Better late than never!

    Thanks Sanj
    This is not the YouView that I knew  :'(
  • joneshjonesh Posts: 1,303Member ✭✭✭
    edited 21 December 2016, 12:03AM
    Sanj said:

    Hi Roy - This issue was reproduced by our test team and is being looked into.

    This issue was reproduced by our test team and is being looked into.

    You said that last time!

    https://community.youview.com/youview/topics/scart
  • RoyRoy Posts: 15,208Member ✭✭✭
    edited 7 December 2016, 8:40AM
    Sanj said:

    Hi Roy - This issue was reproduced by our test team and is being looked into.

    This is a complete b*gger to get across, isn't it, let alone to get it fixed?

    I hope we get some action now.

    It can't be expensive to fix - mere pin money :-)
    This is not the YouView that I knew  :'(
Sign In or Register to comment.