Youview box won't work with new tv

buddy567buddy567 Posts: 3Member
We just got a new tv but the youview box won't tune channels.

If we reconnect to the old tv it tunes absolutely fine, it's not the arial, HDMI cable or youview box (we got sent a new one). What on earth about the tv can affect how it tunes into channels?! 

In settings it shows the signal strength is about 95% but quality only about 18%. 


  • BawmerBawmer Posts: 49Member
    Is the YouView box connected to the Internet, either by direct Ethernet conection to the hub or by Powerplugs
  • buddy567buddy567 Posts: 3Member
    Yes, Ethernet connection. Just been using it to watch netflix. 

    Arial now plugged into the tv direct and picking up channels although no hd channels. 
  • Orange BucketOrange Bucket Posts: 22Member
    Sorry, I got a bit confused over what precisely the problem is. Is it the YouView box itself that can't tune into TV channels, or is it the TV that can't tune into channels when the aerial is connected via the YouView box?

    Do you have the RF passthrough enabled on the YouView box? I believe it still defaults to off. I don't actually need it on with my old box but I'm only a mile or two away from a rather powerful transmitter.

  • buddy567buddy567 Posts: 3Member
    It's the youview box that won't tune in, sorry.
    What is the rf passthrough?
  • RoyRoy Posts: 14,687Member ✭✭✭
    To get your (awful) 95%/18% figures, you must have tuned a channel. Is it that you tuned it with the old TV, and got those figures with the old TV, or that you got them tuning with the new TV?

    What happens if you tune the YouView box on the old TV, get Signal and Quality readings from a channel on the YouView box, and then put it on the new TV, without retuning it, and see what the figures for the same channel are there?

    Are you using exactly the same aerial cables in both cases, not just ones that are nominally similar?

    RF Passthrough is when you wire from wall to YouView box Antenna In (Male to Male aerial cable) and then from the YouView box Antenna Out to the TV (Female to Male aerial cable); this should always work when the YouView box is On, but to have it working still when the box is in (deep?) Standby, you have to have the RF Loopthrough enabled, in Settings.

    How do you have things wired?

    As you say, it seems bizarre that the new TV can prevent the YouView box from tuning (presumably you mean that it will do the tuning process, but find no channels?) and I would immediately suspect an aerial cable issue.

    I don’t even think a fault on the new TV such that the aerial is dead shorted would affect the YouView box; and if there were such, the new TV would not tune any channels at all.

    But you say the new TV will only tune SD channels, not HD ones. What make and model is it? If it is supposed to tune in HD channels, but doesn’t, that is ominous; either the set is faulty, or your aerial setup is.

    Does the old TV, connected directly, get HD channels? If it does, then the new TV may indeed be faulty, and you should get the retailer to check it.

    My money is on aerial issues, though; we had a case recently of a poster with an aerial problem which was traced to a faulty downlead, even though everything seemed to have been OK before the Crystal Palace retune, and that was the suspected cause, but that turned out to be entirely innocent.
    I see the police have a new call-in code: DOE, for ‘Driving Offences Excused’
  • Orange BucketOrange Bucket Posts: 22Member
    I can't remember if RF Passthrough is the current YouView terminology, but it is the setting that enables the antenna out connection on the YouView box that you typically use to chain the aerial through to your TV. By default (on my box anyway) it is off.

    It's not that you don't get any signal passed through to the TV without it enabled (*), but you get a much better one if it is so it should probably be on if you are connecting to a TV as well.

    (*) Well I seem to get one, but then I can get an adequate signal with just the flylead anyway so it isn't always clear.

    It is certainly worth checking that the setting is enabled. If there is indeed a direct connection between input and output then presumably the TV could affect the signal. I'm a bit dubious though.

  • RoyRoy Posts: 14,687Member ✭✭✭
    edited 17 June 2018, 3:13PM
    RF Loop Through to On in Device Management, according to the latest User Guide I have which actually mentions this, for the BT 4K box.

    But that says you have to set your Eco mode to LOW, and Eco modes don’t work like that any more. There is a more up-to-date Guide with the new Eco modes, but it does not mention RF Loop Through any more, and you will look in vain for this in the YouView online help as well.

    Even with the RF Loop Through setting Off though, RF Loop Through operates when the box is On; the setting is to kept it alive when the box is in Standby.

    But whatever, the box needs to powered at the mains, or there will be no Loop Through possible.
    I see the police have a new call-in code: DOE, for ‘Driving Offences Excused’
Sign In or Register to comment.