Youview box cannot get all channels but TV can

Hi, I have a TalkTalk YouView box and have recently left TalkTalk.  However I still want to use my YouView box for catch up TV and recording.  When I connect my TV directly to the aerial socket I get all the channels I need but when I connect via the YouView box I lose half the channels including ITV, Ch4 and Ch5.  It can't be a problem with the aerial due to it working fine direct through the TV.  I'm also struggling to see how it could be the cable as it worked fine whilst I was with TalkTalk.  I've checked the connections, tried rebooting the YouView player and retuned the channels multiple times.  Any ideas?  I'm baffled!  Thanks.

Comments

  • SarahSarah Posts: 958Administrator admin
    Hi @HelenM
    Can you please enter your details into the coverage checker and let us know which transmitter your address is using? The tuner in the box and in the TV are a little different which could explain the difference in channels received. 
    It'd also be helpful to know which YouView box model you are using, you should be able to find this printed on the back of the box or by pressing Help and then Info on your remote control.
    Thanks,
    Sarah
  • John LJohn L Posts: 139Member
    Hi HelenM,
    This is just a thought. Is your Youview box still loaded with the Talktalk ISP software? Does the EPG show Talk Talk or Youview logo on the top of screen? Might be worth going into maintenance mode & doing a software reset with the instructions from this link:
     https://support.youview.com/youview-box/box-and-remote/using-maintenance-mode?q=maint#maintenance-mode-options
    I know I did this some time back on my BT2100 when I had a problem soon after the New Generation software, but I honestly can't remember what the reason was at the time(!). This "may" help to retune all channels missing. Worth a try. As you mention tv is ok with direct signal from aerial, but the box is "thinking" it is still with Talktalk contract, but really this shouldn't be the case with tuning channels. Hope you are able to resolve. John L
Sign In or Register to comment.