BT2100, internet issue

jack000jack000 Posts: 9Member
I have a BT 2100 humax youview box and have an issue keeping my wired internet connection connected.
My broadband connection is on a timer, long story, and if the youview box is turned on before the broadband is on, the box eventually shows its connected via the blue light on the front and the guide preview, but i can not use any apps nor is the my tv preview or pictures on the tiles available.

I either have to go into the settings and click the edit connection auto connect or literally unplug the network cable and then plug it back in, both fix the issue.
If i get any kind of internet disconnect throughout the day, i have to repeat this process.

If the broadband is up and running before the youview box is turned on, it works without any issue.

I have no kind of problems connecting any other equipment to my internet other than this box.

I have done every reset option in the menu and changed the network cable.

Comments

  • RoyRoy Posts: 15,052Member ✭✭✭
    Have you got anything else that makes a dash for the internet straight off, which the YouView box does?

    Having your router on a timer, long story or not, will get you sub-optimum internet speeds. Many routers can enforce blackout periods in their configuration, if that is what you are looking for.

    And if it’s because of what I think it’s because of, they’ll only use 4G instead anyway  :p
    Does HDMI stand for Hardly Dare Mention It?
  • jack000jack000 Posts: 9Member
    edited 28 March 2019, 4:59PM
    There is nothing in the house that hogs the internet in any way, the youview box is the only thing on in the morning.
    The router is set up with an external plug in timer, its not a setting within it.
    Nothing in the house uses 4G, whatever that is.
  • scottscott Posts: 1,947Member ✭✭✭
    edited 28 March 2019, 5:16PM
    jack000 said:
    There is nothing in the house that hogs the internet in any way, the youview box is the only thing on in the morning.
    The router is set up with an external plug in timer, its not a setting within it.
    Nothing in the house uses 4G, whatever that is.


    I think roy was thinking about 'someone' rather than 'something' :)

    Most ISP's use DLM to manage the speed over your BB. Therefore they look for your router to keep a steady constant speed and if they see that constantly will gradually increase your speed to the maximum it can handle before starting to get errors. If you constantly switch off your router at the mains it will not see that nice steady speed and will hold it at a possibly lower speed than it could have. Maybe you are not really too bothered about achieving the maximum speed possible but routers are designed to be 'always on' and therefore most will have scheduling within them if you really want to blank out certain time periods.

  • jack000jack000 Posts: 9Member
    edited 28 March 2019, 5:19PM
    I don`t know what you mean by someone.
    Nothing and no one is using any broadband connection when the youview box is first turned on.

    The broadband is on a timer to stop it being used by the children when no one is around in the morning, if they use it before school, they always end up being impossible to get off and end up being late.
    They turn on the youview box to watch the childrens channels while eating their breakfast, the broadband only comes on a little while later.
  • scottscott Posts: 1,947Member ✭✭✭
    edited 28 March 2019, 5:30PM
    jack000 said:
    I don`t know what you mean by someone.
    Nothing and no one is using any broadband connection when the youview box is first turned on.

    The broadband is on a timer to stop it being used by the children when no one is around in the morning, if they use it before school, they always end up being impossible to get off and end up being late.
    They turn on the youview box to watch the childrens channels while eating their breakfast, the broadband only comes on a little while later.


    Those pesky children is exactly who is meant by 'someone'. I am joking of course when I say pesky its all tongue in cheek. And again that is what is meant by you can set an internal timer in the homepage of the router so although it can stay on it will only be available for internet access between the times you set, hence you can have it off till past going to school time and going off at a reasonable bedtime. It is a very common issue ;)

    It can of course do much more than that by using MAC codes to actually limit certain devices between certain times but that is normally a step too far for most people. Doing things this way allows your line to stay held up and hence no pesky DLM to scupper your speeds while still blocking internet access.

  • jack000jack000 Posts: 9Member
    The only equipment in the entire house affected is the youview box, nothing else loses connection this way.
    My download speed is a steady 19mbps, always has been.

    As i have already said, as soon as the broadband comes on the youview box sees the connection, the blue light comes on, but its not fully connected.
  • RoyRoy Posts: 15,052Member ✭✭✭
    @jack000

    Yiu are using both router and YouView box in a way they aren’t designed to be used, so problems are perhaps to be expected.

    And it will be well worth getting your head round the router configuration manual to see if you can use ‘soft’ timing instead of external power interruption.

    When you see the blue light come on, you should have two blue lights; do you get both?

    However, the Guide preview comes over the internet, so if you see this, you are connected; though if you can’t do the other internet things, the connection must be anomalous.

    I expect the initial handshake has not been completed, and the box does not attempt to repeat it when the connection to the internet is made, so some internet things work, and some don’t.

    I did experiment with my T4000, pulling the Ethernet plug before starting it up, getting the incomplete Guide preview, and then plugging the Ethernet back in; that worked fine, though I see you say it works for you, so I suspect this provokes a new handshake, as does toggling the Connect setting.

    One thing you could try when it is in this state is to touch the On/Standby button for just over 8 seconds; this will make the box soft reset, and this will likely restore the connection. Might even cure your problem also, if some glitch is making the box not retry its handshake when it should.
    Does HDMI stand for Hardly Dare Mention It?
  • jack000jack000 Posts: 9Member
    edited 29 March 2019, 12:40AM
    I have tried all the reset options, nothing works.

    While i agree they can be left on at all times, it doesn`t mean your system should malfunction if you choose to turn them off at night.

    My biggest headache is trying to understand why the blue internet light appears and the guide preview appears, basically telling me i am connected, yet clearly not fully so as the other features do not work.
    Why is it only half connecting?
  • VisionmanVisionman Posts: 9,334Member ✭✭✭
    edited 29 March 2019, 1:02AM
    You are using a YouView box and router in a configuration they were not designed for, so anything can and could happen. i.e. turning one or both on & off, on & off, on & off.

    DLM (Digital Line Management) comes into play here and so could, and often does, interfere with connected equipment. The suggestions you've already been given above are the way to go. Ditch the timer on/off plug and use your routers internal clock to set your internet times, thereby leaving it on 24/7.

    If you don't know how to do that please list your kit (router) and if anyone on here can help they will. Or ask your ISP for technical help in doing it and if they are any good they'll talk you through it.  :)
  • RoyRoy Posts: 15,052Member ✭✭✭
    edited 29 March 2019, 8:39AM
    jack000 said:
    I have tried all the reset options, nothing works.

    Good, that probably means there is nothing wrong with your box.

    While I agree they can be left on at all times, it doesn`t mean your system should malfunction if you choose to turn them off at night.

    See if it still happens when you implement the on/off within the router.

    My biggest headache is trying to understand why the blue internet light appears and the guide preview appears, basically telling me I am connected, yet clearly not fully so as the other features do not work.
    Why is it only half connecting?
    A careful rereading of my posting above, where you will find I offer a plausible explanation for this, may benefit you.

    Further clarification still may be possible if you can kindly answer my question about whether you see two blue lights or only one (a) when the box is half connected and (b) when it is fully connected.
    Does HDMI stand for Hardly Dare Mention It?
  • jack000jack000 Posts: 9Member
    Yes i see both lights at all times

    I have tried the internal timer and get the exact same result.




  • Tim CTim C Posts: 394Member ✭✭
    I think it's important that you tell us what router you're using because with many of them you can either prevent specific devices having internet access between certain times and/or disable wifi between certain times.
    Both these options are far better than powering off the router, which in all probability will shorten it's life.
    “Where’s ‘Jump to Time’ and all that other OldGen good stuff that was promised to come back, including the proper ‘Hide Channels’ etc etc.., rather than the unnecessary & unasked for that does get added and serves no useful purpose? Give me optional lists as well :) ."
  • jack000jack000 Posts: 9Member
    Nothing is preventing the router accessing the youview box, there are no time restrictions or device restrictions when its on.

    As i have said, i have tried the internal timer, removing the external one completely, and get exactly the same results.
  • VisionmanVisionman Posts: 9,334Member ✭✭✭
    As @Tim C asked, make and model of router? 
  • jack000jack000 Posts: 9Member
    Its a Technicolor TG582N, that is 100% working fine on all other equipment and has no settings whatsoever that would make the youview box stop any kind of connection.

    It would be so much easier if actual support tried to help out instead of people that really have no idea what the problem is and just keep asking for insignificant details that change nothing.
  • VisionmanVisionman Posts: 9,334Member ✭✭✭
    edited 29 March 2019, 11:35PM
    Please forgive the attempted help that appears you didn't want, as this is a user forum, not a technical helpline. So just ring them.
    Ta Ta.
  • jack000jack000 Posts: 9Member
    I did want help...
    I keep being asked for info that make no difference to my issue, it would help everyone out if people didn`t try and offer solutions when they simply don`t know how.

    Looking at some of the other threads, this forum seems to have 3 or 4 people on it that fight to be the first to answer question no matter if they know the answer or not and the rest of the time they argue and insult each other.

    I made a big mistake asking for help at all.
    Thread closed.
  • VisionmanVisionman Posts: 9,334Member ✭✭✭
    edited 30 March 2019, 1:03AM
    I understand your frustrated but now do what you accuse others of. Ah well. Good luck with your problem anyway.
  • RoyRoy Posts: 15,052Member ✭✭✭
    edited 30 March 2019, 10:44AM
    @jack000

    This is not a zero-sum game. If one person knows how to solve your issue, and posts accordingly, then this will stand out, no matter how many people offer advice that attempts to help you, but fails to.

    In attempting to reproduce your problem, I was variously advised by the box to look up YVM102, and YVM104. Carrying out the steps under either error code would resolve your problem.

    So why are you asking us (except perhaps to have a vent) when there is not just one, but two, sets of published YouView technical information on how to recover from your issue each time it happens?

    And have you read either of these articles, by the way?

    Oh, and you will find the common key recovery action from both articles described above. Though since you said it “didn’t work” for you, but it did for me (my router is a Netgear Nighthawk I bought retail, as I found the ISP-supplied router wanting), I wonder if there is an additional complication here caused by your router, and it might be worth trying a different model?
    Does HDMI stand for Hardly Dare Mention It?
  • WilfHWilfH Posts: 12Member
    Roy, Visionman et al. 

    Its my my experience that the blue light on the front does not actually represent an active Internet connection. It is merely indicative that the box is connected to an active port - in other words it’s the equivalent of a link light on a network adaptor. I suspect @Jack000’s problem would be solved by assigning the box a static IP address so the box will work without the normal dhcp process and so should work as soon as his internet connection appears. As I recall you need to put the box into and out of standby to force the box to renew the lease on its current IP address and this clearly doesn’t happen in the instance we’re the router comes up when the box is already powered as Roy noted earlier. 

    Wilf
  • Tim CTim C Posts: 394Member ✭✭
    The problem here is that you're trying to do something that goes against common practice for running your devices , namely your router and Youview box. It's therefore difficult for members here to simply solve your problem.

    I've had a look at the manual for your router and there's no simple method of blocking your childrens' device from the internet at specific times. Many other routers do though.
    The manual does state that you can manually turn off the wifi by pressing the Wifi button untill the LED goes off. That might work for a day or two.

    You might try @WilfH 's suggestion in the post above this which if successful would solve your Youview box issue, although turning the router off is not to be recommended.

    Personally I'd either invest in a better router like my Asus DSL-AC68U in which I can shutdown the wifi on a schedule and/or block internet access for specific devices at specific times OR take my childrens' devices away from them at bedtime and not give them back until I thought appropriate.


    “Where’s ‘Jump to Time’ and all that other OldGen good stuff that was promised to come back, including the proper ‘Hide Channels’ etc etc.., rather than the unnecessary & unasked for that does get added and serves no useful purpose? Give me optional lists as well :) ."
  • RoyRoy Posts: 15,052Member ✭✭✭
    edited 31 March 2019, 11:13AM
    Hi @WilfH

    I don’t have a box like @jack000’s, so I have to rely on the manual for it, which says that the right hand blue light is ‘connected to broadband’. Which ought to mean not just on the router, but out through it to the internet, though perhaps it doesn’t.

    It may be interesting, though, that the lights on the T4000 don't cover whether or not you are on broadband, however defined.

    Your suggestion of a static IP address might be something for @jack000 to try, but I think there’s more going on here than that would cover.

    Power up a YouView box with your router switched off, and it will give you a message on the main menu that you aren’t connected, and ought to switch your router on; and selecting Players & Apps, or MyTV, will give you variously YVM102 or YVM104, as I describe above.

    But ignore these and just switch your router on, and the Guide  thumbnails under the Main Menu will appear; these, I believe, come over the internet, and if so, there must be a connection made, DHCP or whatever.

    But you can’t get any Players or Apps, and your MyTV entries have blank thumbnails still.

    Settings/Broadband says you are connected, and I believe you are, judging by the Guide thumbnails. But all other indications speak to the contrary.

    So I think at this point, you are in a sort of limbo where you are, technically, connected, but you aren’t properly connected, and so not everything (indeed not most things) will work.

    There are a range of ways to rectify this; I was surprised to find that going into standby and then turning on again wasn’t one of them, but blipping the Connection in Settings/Broadband is one, as is the 8 second soft reset.

    But we might well take it that the design intention of telling you to fix things by turning on your router, as the box tells you to do  when you turn it on with the router off, is that the box will sense this, and remake the connection properly.

    But it doesn’t, it only half-remakes it. And that neither of YVM102 and YVM104 envisage that you can go into Settings/Broadband, and find that even though it says Connected, you should ignore this and Connect again, and this will make it connect properly, indicates that this is not a planned-for scenario.

    So no matter how unusual @jack000’s breakfast-time arrangements may be, it does seem that what is happening for him shouldn’t be, and the box really ought to recover unattended, and fully, when the internet connection is restored.

    I call ‘bug’ here, I think.
    Does HDMI stand for Hardly Dare Mention It?
  • VisionmanVisionman Posts: 9,334Member ✭✭✭
    edited 30 March 2019, 9:20PM
    WilfH said:
    Roy, Visionman et al. 

    Its my my experience that the blue light on the front does not actually represent an active Internet connection. It is merely indicative that the box is connected to an active port - in other words it’s the equivalent of a link light on a network adaptor.
    Hi @WilfH. Yes thats bang on. Having the blue light on does not necessarily mean the box has an internet connection and indeed is not indicative of such. And constantly turning equipment on and off would only exacerbate that connection.

    So in this thread what we have a user actively choosing to use his equipment in a non-standard configuration (personal circumstance accepted) and then blaming the YouView box because it won't work properly. But don't they all?  
  • RoyRoy Posts: 15,052Member ✭✭✭
    edited 31 March 2019, 11:15AM
    Visionman said:
    WilfH said:
    Roy, Visionman et al. 

    Its my my experience that the blue light on the front does not actually represent an active Internet connection. It is merely indicative that the box is connected to an active port - in other words it’s the equivalent of a link light on a network adaptor.
    Hi @WilfH. Yes thats bang on. Having the blue light on does not necessarily mean the box has an internet connection and indeed is not indicative of such. And constantly turning equipment on and off would only exacerbate that connection.

    So in this thread what we have is a user actively choosing to use his equipment in a non-standard configuration (personal circumstance accepted) and then blaming the YouView box because it won't work properly. But don't they all?  
    Hi @Visionman

    That would mean though, I think, that you find some fault in my close analysis above.

    What fault would that be?
    Does HDMI stand for Hardly Dare Mention It?
  • VisionmanVisionman Posts: 9,334Member ✭✭✭
    My comment wasn't about your comment, @Roy so my apologies if it came across that way as that wasn't my intention.
  • RoyRoy Posts: 15,052Member ✭✭✭
    edited 1 April 2019, 12:03PM
    Visionman said:
    My comment wasn't about your comment, @Roy so my apologies if it came across that way as that wasn't my intention.
    No apologies necessary @Visionman.

    But my comment was rather more than just a comment, it was a description of some practical experiments with a T4000 that suggest there is a discrepancy between what the box and the Help say, and what actually happens.

    Where what the box and the Help say is leading @jack000 to a reasonable expectation that his box should auto-recover from his breakfast-time arrangements, however unorthodox they may be, and it doesn’t.

    i.e. the conversation has gone:-
       ”Doctor, it hurts when I do this”
       ”Well, don’t do it then”
    without any serious consideration of whether it ought to hurt or not.
    Does HDMI stand for Hardly Dare Mention It?
Sign In or Register to comment.