Youview box wiping out programs on LG wireless smart TV?

FrogeyeFrogeye Posts: 2Member
I have just bought an LG wireless smart TV.  Set up procedure fine and Youview box connected via HDMI 1.  All good and able to watch old recordings and old scheduled recordings still happening. The TV is connected via a power plug using the ethernet cable to the BT Hub. (The ethernet cable is in the ethernet port on the back of the TV NOT the box as this caused the picture to jerk and flicker).  However each morning when the TV is turned on the image of the HDMI 1 connection is shown and then the TV displays a pretty picture and the words NO PROGRAMMES.
I then have to re programme.  When this is done there is no problem for the remainder of the day and into the evening.  Next morning the same thing happens.  Please someone explain, in simple terms, why???

Comments

  • Tim CTim C Posts: 443Member ✭✭
    I'm very confused by this, so I'll ask a number of questions (in no particular order).

    Why are you not using the wifi on the TV, is the signal not good enough?

    If the Youview box is off and the TV is switched to HDMI1 then you'll get ,usually, a No Signal message.

    Does the TV aerial firstly go into the Youview box and then loop out of that to the TV? If so then it's important that the setting in the Youview box allows for the aerial signal to be passed through to the TV. It's Settings ->Picture & Sound and Antenna Out set to On.

    The Youview box really needs to be connected to the internet so if using ethernet for the TV then you need a 5 port switch , fed by the ethernet cable from the Power Line Adapter,so that then both devices can be connected by short ethernet cables from the 5-port switch.

    Hope this all makes sense!
  • RoyBRoyB Posts: 30Member
    edited 4 December 2019, 11:54AM
    @Frogeye

    I never heard of jerking and flickering that could be solved by moving an Ethernet cable, except perhaps a faulty one, but I imagine the one you have has been working fine with the YouView Box before?

    So either your new TV is faulty, or you have set things up wrong here.

    So, further to the sound and sensible advice @Tim C gives :-

    You can’t run the YouView box without an Ethernet connection, as though it will still work to receive TV programmes, none of the thumbnails will show. This may be part of what you are seeing.

    The first thing you need to do is drop the YouView box out of the equation, so power it right off (don’t even have it on Standby). Take the Ethernet cable off the TV, take the HDMI cable for the YouView box off the TV, put the aerial cable from the wall directly into the TV.

    Does the TV show broadcast programmes, both SD and HD, OK?
    (If you haven’t tuned them in, tune them first, try again).

    If not, then either the TV or the aerial system is faulty. And if the aerial system was OK before, then excluding bad connections provoked by moving the cable, likely you have a faulty TV.

    Does the TV show the BBC iPlayer OK?
    (If you haven’t set the WiFi up on the TV, set it up now, and try again).

    If still no go, try a portable device, like a smartphone or iPad, near the TV, and see what the WiFi strength is. If it looks OK, this part of the TV may be faulty.

    If the smartphone shows your WiFi in that spot is poor, though, then put the Ethernet connection back on the TV and try the BBC iPlayer again.

    If this now works, then plan to follow Tim C’s advice to get a 5 port switch (about £15 from Curry’s or wherever, and you will need two extra Ethernet cables if you don’t already have these), and connect the TV and the YouView box both via that to your Ethernet. 

    (But leave this consideration aside for the moment, and carry on testing here).

    Now power the YouView box back on, put the aerial cable back on the YouView box, put the Ethernet on the YouView box, reconnect YouView box and TV via the HDMI cable.

    Now, just using the TV purely as a device to watch YouView, does it all work OK?

    If so, done deal, though as Tim C says, always good to loop through from YouView box to TV with an extra aerial cable (male to female or male to male with a female coupler) configured as he describes, and you may need the Ethernet switch he describes if the testing above indicated that you do.

    If you still have problems with jerking and flickering, after all this, then try a different HDMI cable, unless this is a known-to-be-good one used between the YouView box and your previous TV.

    If the problem persists, though, then talk to whoever you got your new TV from. Ask them to sort it out, or replace it if it is faulty.
  • Rob PRob P Posts: 53Member
    Hi @Frogeye,
    I may be able to help regarding the "no programmes" message that you're seeing with the picture. But I'm assuming that it's the TV's tuner that's lost its programmes, not the Youview box, as I had exactly the issue that you describe on my LG.

    By default the LG is set to scan for programme tuning updates overnight. And by default, the Youview box is set to go into power saving mode overnight and stops passing the aerial signal through to the TV. In a stupendously bad bit of design, finding no programmes at all the TV then deletes all those that it had stored and goes back to sleep. You turn on in the morning none the wiser and boom - no programmes.

    You have two ways to resolve:
    1. Stop Youview from sleeping: In the Youview settings you could turn off the power saving, ensuring the TV doesn't lose signal overnight: Settings > Power & Standby > set Standby Mode to Always Ready

    2. Stop TV from scanning: Go to Settings (cog button) > All Settings > Programmes > Programme Tuning & Settings. Here, turn off the Programme List Update option. You will be asked to confirm.

    I went with option 2 on the TV and it's solved the problem. You will still be prompted when tuning changes are required, and you can then initate tuning yourself.

    @RoyB and @Tim C have given great advice regarding the ethernet/wireless so I won't add to that, but I don't believe your tuning issues are related to that.
    Hope this helps,
    Rob
  • FrogeyeFrogeye Posts: 2Member
    Thank you for your time and advice.  I just rely on logic and no technical knowledge. A friend who is an electrician helped me set up the tv and YV box and he put the ethernet cable into the tv and not the box.  I connected it to the box later as that was where it had been.  Thats when the flickering occurred. The thumbnails showed then but when the cable is in the back of the tv it just shows the titles of the progs and I can see the tv picture in the background. However it is working and I can watch past and current recorded progs.  All apps can be accessed via the tv including BBC iplayer and the rest.  In fact during the entire day and late at night until I switch it off at 11pm, all works fine and this includes me switching the set off for long periods during the day.
    If it works completely ok for over 12 hours why does it pack up at night??  I had to reprogramme again this morning.  Takes me a couple of minutes but it is a puzzle and irritating.
    Will follow your suggestions over the next day and get back to you.
  • RoyBRoyB Posts: 30Member
    Hi @Frogeye

    Glad you got so far anyway. I don’t think YouView is part of ‘the regs’, so your electrician friend may not be as familiar with it as he could be  :p

    I don’t quite know what you mean by ‘reprogramme’, though. Reprogramme what, and how, to do what?

    And I hope when you talk about switching off the YouView box you just mean putting it into standby?

    But one thing that might be happening here is that when you turn the YouView box on, it switches the TV to HDMI 1, but it doesn’t switch the TV back to TV (broadcast) when you switch it off again.

    So expect to have to press the SOURCE button on your TV remote, and change this back to the broadcast TV setting every morning, to watch the TV without YouView.
  • Stevef_fr8ysStevef_fr8ys Posts: 175Member ✭✭
    Roy is correct re source.
    I have LG TV and have a magic remote. Not sure about other remotes but click the button looks like the with  lead then select the youview box.
    If have set up the box correctly with the TV, turning the box  should also turn on the TV, so if the box was the last source, it should start the TV once the screen comes on.
  • Rob PRob P Posts: 53Member
    Hi @Frogeye ,
    I may be able to help regarding the "no programmes" message that you're seeing with the picture. But I'm assuming that it's the TV's tuner that's lost its programmes, not the Youview box, as I had exactly the issue that you describe on my LG.

    By default the LG is set to scan for programme tuning updates overnight. And by default, the Youview box is set to go into power saving mode overnight and stops passing the aerial signal through to the TV. In a stupendously bad bit of design, finding no programmes at all the TV then deletes all those that it had stored and goes back to sleep. You turn on in the morning none the wiser and boom - no programmes.

    You have two ways to resolve:
    1. Stop Youview from sleeping: In the Youview settings you could turn off the power saving, ensuring the TV doesn't lose signal overnight: Settings > Power & Standby > set Standby Mode to Always Ready

    2. Stop TV from scanning: Go to Settings (cog button) > All Settings > Programmes > Programme Tuning & Settings. Here, turn off the Programme List Update option. You will be asked to confirm.

    I went with option 2 on the TV and it's solved the problem. You will still be prompted when tuning changes are required, and you can then initate tuning yourself.

    Hope this helps,
    Rob
  • RoyBRoyB Posts: 30Member
    @Frogeye

    @Rob P has missed a third option here, probably the best one, which @Tim C described above:-

    Does the TV aerial firstly go into the Youview box and then loop out of that to the TV? If so then it's important that the setting in the Youview box allows for the aerial signal to be passed through to the TV. It's Settings ->Picture & Sound and Antenna Out set to On.

    As I have said above, you don’t want to power the YouView box right off overnight, because even with the above setting, there will be no aerial signal passed through, and the LG TV will do its party trick, unless you do @Rob P’s option 2 as well, and lose this automatic feature; instead, leave the YouView box in Standby.


Sign In or Register to comment.