TV players (ITV Hub, iPlayer etc) continual buffering

Mark1954Mark1954 Member Posts: 3
Model DN372T
I'm unable to use the 'catch up' apps. Interface pops up fine but no programme will play. Amazon Prime works fine, so it's presumably not the connection. I can use the various TV players on other devices so, again, it's not the router or the broadband speed.

I've just recently changed ISP from Talk Talk to Now TV in part, because this problem was already happening but not to the extent it is now (but mostly because I'd had enough of their customer service fails).

I've reset the box and installed the latest available software. All to no avail. I'm reluctant to do a factory reset unless it's absolutely necessary (a couple of my recordings are worth hanging on to). At the moment, the box is connected to the router via power line adaptors - is there a better option?

Can anyone offer any advice? Thank you in advance.
Tagged:

Comments

  • RoyRoy Member, Super User Posts: 15,787 ✭✭✭
    @Mark1954

    Amazon Prime on the YouView box, or on something else?

    Heve you tuned the YouView box in, on a terrestrial aerial? You won’t get the catch-up players if you haven’t.

    Look up YouView Maintenance Mode on Google, and try an Option 2 - that’s quite a good reset, and preserves your recordings.

    A straight-through Ethernet cable Is simpler than PLAs; but I do my tech support job over PLAs, 24/7 sometimes, and you can’t get much more demanding than that. And they have never let me down, or even slowed me down.

    But it’s worth doing a flight of reboots starting with the router, then the PLAs, router end first, and finally the Option 2 on the YouView box.

    See if any of that fixes things,
    Three cheers for reasoned debate, whether for or against
  • Mark1954Mark1954 Member Posts: 3
    Thanks for the suggestions, Roy. Very kind of you to bother. In order:

    Amazon Prime on the YouView box, yes.
    Yes, terrestrially tuned.
    I’ve done the maintenance mode reset.
    That’s reassuring to hear about the PLAs.
    I’ll try the various resets - in that order!

    I suspect it’ll have to be a factory reset ultimately. Boo hoo!

    Thanks again for your help. Much appreciated.
  • joneshjonesh Member, Super User Posts: 1,400 ✭✭✭
    edited 21 June 2020, 10:43PM
    Does BBC iPlayer work?
    We had problems with the commercial catchup apps not working after adverts, but iPlayer worked fine. The problem disappeared when I replaced the PLAs with a cable.

    edit:
    I just  noticed that you said that iPlayer doesn't work in the title of your topic. :blush:
  • Mark1954Mark1954 Member Posts: 3
    I've gone for a factory reset - I also reset the router and the PLAs as Roy suggested. It looks promising!
Sign In or Register to comment.