Players won't play programmes

RabidRabid Member Posts: 1
This morning I had a short powercut. Now the players (bbc iplayer, All 4, etc.) On my TV won't work. My boxset is YouView TalkTalk tv boxset (model DN370T.02.04.P)

The players open and show some of the program thumbnails fine (others aren't shown, they just have default player-specific background images) but attempting to watch any program results in an error saying something to the tune of "this content is currently unavailable. Please try again later."

Furthermore, the normal thumbnails and fonts in the list of players (shown when I press menu on the remote and scroll to "Apps & Players") have all been replaced by grey boxes with default white font for each player's name. The YouView help app videos also have these grey box thumbnails and won't play.

The box says it's connected to my broadband in settings. I've tried restarting the box, TV and retuning my channels. Any help would be greatly appreciated!
Tagged:

Comments

  • John LJohn L Member, Super User Posts: 728 ✭✭
    Hi @Rabid, welcome to the forum,
    Have you rebooted your Router + also maybe if still a problem, recheck your powerline adaptors are still connected correctly? They might have lost their pairing code with Router after powercut/surge going back on. Then if this still doesn't work, check internet connection on the Youview settings again. Please let the forum know how you get on/if you need more advice. John L
    Can't wait for the day when Youview get rid of the dreaded darkened banner when using fast forward/rewind recordings. 
Sign In or Register to comment.