BT Youview box not opening apps

Mac4Mac4 Member Posts: 1
My box was working fine yesterday, today it won’t open any of the apps. The programme guide works ok and recordings play ok. Tried checking internet connection and restarting the box but no luck. Want to avoid a reset as I’d lose all my recordings. My Netflix subscription expired yesterday, could this be the cause of the problem, or just a coincidence? I’ve signed out of Netflix. Any suggestions please? 

Comments

  • RoyRoy Member, Super User Posts: 17,059 ✭✭✭
    edited 11 December 2021, 5:30PM
    @Mac4

    Greetings and welcome to the Community!

    The Netflix thing is a coincidence.

    What exactly happens when you try to start an app?  

    When you go to Settings/Broadband Connection, what do you see?

    How is your box connected to the router, direct cable or via PowerLine adapters?

    Try rebooting your router, and when it has settled, reboot the PLAs (if applicable, starting with the one nearest the router) and try the YouView box again.

    Come back with the answers and if still no go, we can dig a bit deeper.
    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
Sign In or Register to comment.