Can't update my apps

c_oldfieldc_oldfield Member Posts: 1
Hi, I think I have an old model DTRT2120. My All4 app isn't the latest version, when I tried to update my apps I got an error message saying to visit the youview help site. Do you know if there is a way to update my apps? 
Thanks

Comments

  • kodikidkodikid Member Posts: 970 ✭✭
    To be honest if you want the most up to date apps and vastly superior choice you're better investing in a fire stick etc.

    I use my youview to record terrestrial channels but stream through a roku device. 

    Youview has many strengths, App's are not one of them
    Ignore this if you disagree. Oh wait I just remembered I don't give a 
  • RoyRoy Member, Super User Posts: 17,401 ✭✭✭
    edited 15 June 2022, 8:28PM
    Hi, I think I have an old model DTRT2120. My All4 app isn't the latest version, when I tried to update my apps I got an error message saying to visit the youview help site. Do you know if there is a way to update my apps? 
    Thanks
    @c_oldfield

    Have you got this box set up so that it is connected both by an aerial cable to a terrestrial TV aerial, and by an Ethernet cable, possibly with PowerLine adaptors to your router?

    You can’t individually update your box or your apps; you just have to make sure it’s connected as above, and then it will check in with YouView and update itself.

    The manual update options might bring this forward, but only if there are updates ready, and scheduled to update overnight.

    What version is your All4 app? I can have a look to see if this is the latest version available to T2xxx YouView boxes,

    Even if is is not, as @kodlkid explains, the very latest version, which might only be available on one of the devices he mentions.
    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
Sign In or Register to comment.