pixellating picture

I Have a Humax DTR-T2120/500G/Plusnet which has begun pixellating the picture. It's approximately 2 years old and no longer supported by Plusnet. Aerial signal is good and works on direct connection to TV.
I've tried a factory reset, but this resulted in the pixellations becoming much worse.
Any suggestions to help,  gratefully received .
Regards
Brian

Comments

  • Stevef_fr8ysStevef_fr8ys Member, Super User Posts: 662 ✭✭
    If this is a sudden thing it could well be weather related and will improve when the weather settles down.

    You say it's ok using the TV tuner. TV tuners are usually able to process signals better than PVRs, so this to could be a factor.

    During hot weather it's usually best not to retune as you will lose channels and it can make the situation worse.

    I you want to try and improve this now that you have retuned, I suggest that you retune with the aerial disconnected so you wipe any residual memory from the box, reconnect and try again.

    Let us know how you get on and also which region you are in.

    Thank you.
  • cb1000rabscb1000rabs Member Posts: 4
    Hi Steve

    Just tried those options with not very good results . When I retuned again I got 6 channels. I usually have around 160. Did another factory reset and retune with the same results. I'm in the North West with the options of Liverpool or Preston. I'm in the Preston area so that's always been my choice. The tuned channels are 007, 050, 052, 061, 068, 207. ps My phone's now playing up and giving me bold text **? Hope there's a solution. Regards Brian






  • Stevef_fr8ysStevef_fr8ys Member, Super User Posts: 662 ✭✭
    Are the tuned channels on your TV playable?
    With this few channels being tuned, it's either an aerial problem or the tuner on the box is failing. If your TV has all channels working, using the same aerial cable plugged directly into each device, then I suspect it's the box failing.
  • cb1000rabscb1000rabs Member Posts: 4
    Looks like the box tuner's on the blink. All channels on the TV working correctly. Time to search for a new PVR.
    Thanks for your help.
    Regards
    Brian
  • RoyRoy Member, Super User Posts: 17,520 ✭✭✭
    edited 18 August 2022, 8:25AM
    Looks like the box tuner's on the blink. All channels on the TV working correctly. Time to search for a new PVR.
    Thanks for your help.
    Regards
    Brian
    @cb1000rabs

    Are recordings and catchup pixellating as well, or just the tuners?
    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
  • cb1000rabscb1000rabs Member Posts: 4
    Recordings were all ok, until I did factory resets. Now gone of course. Tried another factory reset and 2 separate retunes. Left with 6 channels, instead of about 160.
    Think it's the end of the line and I'll have to replace.
    Cheers
Sign In or Register to comment.