Prime Video

Had a problem with my box and had a new box sent out. It’s been working fine but now I keep getting problems with prime.
It keeps displaying “something went wrong”
Ive deregistered the box and then re registered it.
Restarted my hub.
Changed Ethernet ports.
Turned box off and waited then powered back up.
No problems with any other channels.
All updates carried out.
It really is annoying.

Comments

  • RoyRoy Member, Super User Posts: 17,656 ✭✭✭
    edited 31 December 2022, 10:16PM
    @grasscutter

    Greetings, and welcome to the Community!

    Which YouView box? Which ISP, and are you on a subscription (it sounds like you may be)

    If so, your ISP may be your best bet; but there are a couple of things you can try first.

    Firstly, a soft reset by touching the On/Standby button for just over 8 seconds, until the box soft reboots. This is slightly better than a power cycle reset.

    If this doesn’t help, try a Maintenance Mode reset:-
    https://support.youview.com/youview-box/box-and-remote/using-maintenance-mode/

    Option 2 refreshes the software internally; the more thoroughgoing Option 4 refreshes it from YouView’s servers. Both preserve your recordings, though not much else.

    These resets can correct any issue caused by corrupted YouView software not handling the Prime app correctly, but obviously can’t correct any issues within the Prime app software itself. 

    However, this seems to be working fine on my T2100 at present. ISP BT, FTTP, but no BT TV subscription.
    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
  • RohitRohit Administrator Posts: 52 admin
    Hi @grasscutter

    On top of the points from @Roy above, could you tell us when you're seeing this error screen e.g. when browsing content, or pressing play, or during playback? 


Sign In or Register to comment.