[DISCUSSION]Have a DN370T Box originally talk talk who I left has gone to Maintenance menu 70.44.212

Max2010Max2010 Member Posts: 29
edited 17 May 2018, 8:28AM in Support
This box was fine up until last week when it started locking up . I then had to turn it off several times  as it would not change channel even with new batteries. The box kept doing this until i updated software now when i turn it on it gets to maintenance menu and wont go further is there something wrong with this recovery update 232024 ?

Te box is running :
Recovery Software:232024
Manufacturer Software version: 70.44.212
Front Panel Software: 105008.

I have tried all the options on the Maintenance menu and nothing gets box to restart in a working condition. I tried to find a USB download to put a different version on the box but these do not seem to be available on the  Internet.

Can anyone help as its just becoming a dust collectible or dumpster candidate


  • Max2010Max2010 Member Posts: 29
    I was hoping someone could point me to USB downloads so i can put old version back on it . Since it destroyed my recordings i don't have much confidence left. I expected a total reset to at least work if it destroyed my recordings in the process. It didn't do anything different but delete recordings
  • Max2010Max2010 Member Posts: 29
    edited 15 May 2018, 5:03PM
    How do I force the box to get software update from maintenance menu forced start and inability to progress further as I think my software is not update. Is there a keyboard sequence to get software update?
    My box was working properly until It started not recording  and only recording 5 mins of programs. The box then started locking up on a channel and then not allowing any button on remote to work that lite up. I turned the box of several times to get this to open. I eventually did a software update which resulted in  a failure  to start up I have software 77.44.212 this is not working . How can i manually update from USB with a different version and how do i locate a different version that does work. This process has already destroyed my recordings. Why do you release updates if they are not tested?
  • Max2010Max2010 Member Posts: 29
    i tried pressing start +- volume after turning box of and on and get same menu 
    "Your box has failed to start  properly
    The box will now enter maintenance-mode, where you can select a recovery operation

    Pressing [OK]
    gets to a menu 
    Software Reset[Recomended]
    Factory Reset,  keep recordings
    Factory Reset,  delete recordings
    Internet/USB recovery , keep recordings
    Internet/USB recovery , Delete recordings
    Exit and restart

    None of the five options do anything but return the box to the  fault  ""Your box has failed to start  properly". I only encountered this after updating software after the box was locking up and not recording programs but recording 5mins of them and not able to change channel on the box after 5 mins of viewing .

    What is going on are your technical people releasing untested code?

    I presume i have lost my recordings and this box is fubar unless i can force it to download a different software version which does not seem to be documented?
  • SarahSarah Member Posts: 1,812 admin
    edited 15 May 2018, 5:03PM
    Hi Max,

    Just to confirm, you are not able to get to any other area of the box apart from Maintenance Mode and when you've performed a Maintenance Mode, it requests you to do another one again? If this is the case, it does sound like your hard drive may have gone. If you were still with TalkTalk, we'd recommend contacting them for a replacement but as this is not the case, please drop us a call and our team can try to troubleshoot the issue in case there's something which can be done to resolve the situation. 

    Just to keep things a bit simpler for us to keep track of, can you reply to this thread rather than posting about the same issue in multiple places as it makes it a bit trickier to go through the information. This can also cause your posts to get caught in the spam filter as you've posted the same/similar thing at a fairly high frequency across the forum. I've moved some of your other posts into this thread to keep the ones about the same problem in the same place. 

  • Max2010Max2010 Member Posts: 29
    edited 15 May 2018, 5:25PM
    Hi Sarah
    I am no longer with TalkTalk as the hiked my monthly costs of my account and would not provide me a letter stating that they would keep my payments the same for the duration of my 18 month contract . I was also one whose information was hacked under the hole in their system. I joined a more reputable supplier.

    I tried the stb internet update and it does the same thing .

    Is there no way I can get a USB update . If I remove drive as its out of warranty and format it in a caddy  will this solve the issues. Or failing this buy a new hd and fit it in place of the one in the box. Will the firmware format a new drive with your software?

    Am not posting all over the place . I am having these same problems as others before this box went like this . The threads I commented on seemed to be starting with the fault I was seeing.  Also my post was removed for some reason so did not expect it to return. Why would the locking up of the box playing a tv program properly locking it to the station  have anything to do with the hard drive?

  • Max2010Max2010 Member Posts: 29

    If the  HD was faulty would the STB update not fail updating software it doesn't fail and completes the update with the bar traveling right along and a restart without error  . Presumably this is software update is recorded on HD?
  • Max2010Max2010 Member Posts: 29
    no answer then?
  • Max2010Max2010 Member Posts: 29
    I guess i will have to use it as a door stay opener and go buy something decent  or format drive
  • AnaglyptaAnaglypta Member, Super User Posts: 867 ✭✭✭
    Max2010 said:
    no answer then?

    I think @Sarah has a life outside of YouView. I'm sure she will be back tomorrow to answer your questions.

    "Never tell people how to do things. Tell them what to do and they will surprise you with their ingenuity." - George S. Patton
  • Max2010Max2010 Member Posts: 29
    edited 15 May 2018, 8:01PM
    Ok So I reluctantly opened up box as it was out of warranty and unplugged drive and connected and old laptop drive i had same sort of size in its place ontop of old one . I got exactly the same error on start up:
    "Your box has failed to start  properly
    The box will now enter maintenance-mode, where you can select a recovery operation

    I ran the USB/ Internet update with clear recordings. This took the same time to download as it had before with no errors. This finished and went through waking up, Please Wait Use SMART Mode for faster startup, Loading. Waking Up and the same start up message error.

    I am presuming this is then not hard drive but the software download that was downloaded from the supplier that caused this fault and my lost recordings. I have put this all back together and hope Sarah has a better idea now of what is wrong .  A question on a different front what is the maximum size drive this unit will support will it support a terabyte or half a terabyte drive? 

    Can Sarah give me a reason why when i replaced the drive the same fault existed please as this is indicative of he software release and the issues i experienced to start with I have observed in the forum, I am guessing this is likely to be one and same fault. That is not being identified or corrected.
  • Max2010Max2010 Member Posts: 29
    I think i am going to have to dump this and go humax  as I dont think the software updates are being provided diligently on this box I have also lost more than 80 recordings of series and films which have been deleted of my box which sucks 
  • RoyRoy Member, Super User Posts: 17,596 ✭✭✭
    Hi again @Max2010

    Can we clear up a few misconceptions?

    I now learn you have an ex-TalkTalk-subscription DN370T.

    But you haven’t just updated it, as the software version you are quoting dates back to last December, and isn’t the latest 70.45.146

    You may well have tried the software update option, but no update took place.

    So it’s not that your software release hasn’t been tested properly; hundreds of people, I expect, have this update, and it is working fine for them, but your update attempt has coincided with a failing hardware situation (which it may or may not have exacerbated).

    Sarah thought hard drive might be the culprit, which is highly likely; and yes, if you put a suitable replacement hard drive in a healthy YouView box, it will format it the way it wants it, and should run OK after that, once the initial setup has been repeated.

    But as this didn’t work for you, either the hard drive wasn’t a suitable one or (much more likely) there is a hardware fault or faults elsewhere in the box.

    And yes, when a YouView box fails, your recordings, or at least all the HD ones, are toast, and there has never been a way of backing them up, and yes, it sucks.

    But it sucks just as hard on pretty much any other PVR as well, be it Humax YouView, Humax non-YouView, or non-Humax.

    You can, if you are reasonably tech-savvy and the drive from your failed box is actually sound, hook the drive from your failed box up to a PC and rescue any SD recordings you have; this may be worth a try.

    Beyond that though, looking at some of the issues people are reporting and adding that your box did the same isn’t really helpful to you; the issue I had with scheduling going awry was fixed with the most basic soft reset, which is generally the case when the running software in the box gets a little corrupted, but refreshing it gets it back on track.

    But you are far beyond that point, with hardware issues that are likely terminal; and no YouView software release on a USB stick, even if there were such a thing these days, which there largely isn’t, is going to help you.

    Do though, try the YouView Helpline as a last-ditch option, in case there is anything they can suggest to help.
    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
  • Max2010Max2010 Member Posts: 29
    edited 16 May 2018, 8:52AM
    Hi Roy,

    Thanks for the comments yes it was a DN370T before i started yesterday using it as a door stop and switched back to sky box.  The box was running correctly but two days ago it started not completing recording. I noted there was lots of watched recordings and a few kept recordings 

    I left TalkTalk after i was lied to by the disconnection team who would not give me a letter stating my contract price would stay the same over the whole eighteen months contract. The box continued to work without fault and was the only thing that TalkTalk supplied that did work as the internet connection was dreadful. This was bad as I had been a talk talk customer form many years.  This and the hole in their online software giving personal data away  was the last straw. It seemed that TalkTalk was more concerned with new customers and didn't care about its core of regular customers.

    These box failures  all started to go wrong last week
    1) Two recordings in the morning failed putting up an icon with 2 mins of recording. I deleted them and it did the same thing the next day as they was on series link. This was annoying and one was on Blaze.
    2) I ran the settings update to update the box menu from the new icons. This caused the box to start behaving oddly as soon as it rebooted . It would wake up onto a channel that it would play but could not change unless it was changed in the first few minutes. This channel would then stick in place and could not be changed. It would switch off through the power button. This then failed further and I had to switch of at the back of the box. Two or three days a go i was presented with a maintenance menu which stated that Startup had failed.

    3) It gave me a list of options that none of the options cleared the fault. The only one that functioned as I expected was the USB/Internet update which ran and rebooted box
    4) I ran all the other options and no option on any of these menus would clear this fault.

    I searched google for an update 70.45.146 as I am aware that my version  70.44.212 is not the same as shown on this website. I expected to be able to either download this update on my box or download it from the internet for my device to a USB drive and apply it from the drive.

    However the maintenance mode Internet update does state it is downloading the latest version for the box so I have to state it is the latest version according to your software maintenance mode!

     This information was not forthcoming and the matter was raised on community forum as to were this usb download was located?

    I hope this message  helps the forum as its clear something is a miss with the software being delivered through maintenance mode. I have only called this software latest update  as its what your maintenance mode in your software calls it. 

  • SarahSarah Member Posts: 1,812 admin
    Hi Max,

    I've forwarded this onto our team for some suggestions in case they know of something which may be causing this but it does sound likely that something in your box has been struggling and is now going in loops and not working correctly.

    I'll update you once I hear back from them however for now, we do recommend you giving our call centre a ring so they can go through some steps to try and get the box working again. 

  • Max2010Max2010 Member Posts: 29
    Thank you Sarah this is quite frustrating as you know . I am sure other users are experiencing similar issues . If the box maintenance-mode states its update to latest version . Why does it not do this what it is saying it is doing? Its downloading something as the progress bar goes across and finishes restarting the box , but the version number stays static?

  • Max2010Max2010 Member Posts: 29
    I am ringing them at moment , Thank you Sarah

    They said they are not aware of this type pf problem I told them about replacing hard drive and was told that this would not have worked as the drive needs 5 partitions that cant be copied. Your agent then when onto inform me that the maintenance mode would have formatted this partitions and brought in the software when i ran the maintenance options to format the drive and bring in the software. No one has explained to me why this box has not been updated with latest software . I have informed the rep case to their head office.
  • Max2010Max2010 Member Posts: 29
    Allan gave me a case reference of 00164278
  • RoyRoy Member, Super User Posts: 17,596 ✭✭✭

    I can explain it. Your box is faulty; it is the hardware; it isn’t the disc drive.

    Nobody else with a fully working box is having problems with this upgrade, because on a working box, it will update just fine.

    As you described, you were having issues with the box before you attempted the software update; so while it may have turned into a doorstop during that, it was probably already on its way out.

    The software processes, both update and maintenance mode, are assuming they are running on a working box. But they aren’t, so the messages are more describing what the software is trying to do, rather than what it is succeeding in doing.

    In particular, it may well have described that it was upgrading your software release, but the fault in the box would not let this run to completion. So the software release is still the previous one. Why would you believe that the software has been updated because a message in a failed update said so, and yet not believe the software is still on the version the box says it is on?

    And something got lost in translation in your chat with the YouView agent; replacing the disc drive, on a box not otherwise faulty, would, as you describe him saying, result in a newly and correctly formatted disc drive that you could carry on using the box with, albeit as if you had only just bought it, empty and yet to be initialised. 

    So what is it that “wouldn’t have worked”?

    And YouView updates, for the box-using population, arrive only via the internet, direct from YouView. There are no sources to get these from the web, or via USB sticks. And think about the very limited circumstances in which a USB stick would be useful; a box with OK hardware, on which an MM2 would largely work, but not allow the box onto the internet to fetch an MM4 update, whereas it could right itself from a local source.

    A pretty limited set of circumstances; though if you were actually in them, which I somehow doubt you are, then I dare say one would be forthcoming from YouView Towers.

    Anyway, I’m glad you got a ticket. I’m sure that if there is anything that can be done to get your box motoring again, then YouView will do it.

    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
  • Max2010Max2010 Member Posts: 29
    edited 17 May 2018, 8:39AM
    Hi Roy, This is not quite correct according to the engineer i spoke to on the telephone.

    1) I was told if the software boots and goes through waking mode to three other screens then the hardware is functioning correctly to lod software.
    2) I was told swapping hard drive eliminated hard drive as it was formatted by the software eprom and then gave same fault.
    3) I was told the maintenance-mode options will format a drive and partitions! Making it the same as the resident drive eliminating the drive from the problem.
    4) No explanation was given as to why the latest update was not being downloaded
    5) No website address or download address has been emailed to me or supplied to obtain the latest software to put it on a USB key. I was told this was for just a keyboard when maintenance mode states clearly it is for also updating from USB key "Internet/USB recovery , keep recordings".

    I am awaiting the response I am aware other users are having connected issues with software. These are clearly shown on forums: 
    1) lost Video thumbs 
    2) Maintenance-Mode not resolving issues System Error on box.
    3) Not saving complete recording only putting a thumb picture and two mins or more recording saved.
    4) non locked recordings not being deleted to make way for new recordings
    5) Not downloading current software version
    6) from google not being able to find a usb software release.

    I hope this helps as it according to complaints on this forum seems to be right across the Youview box range and not just my own box. I am therefore believing it is software related.

    I expect the drive has a boot strap which contains the version of software on the box . I would wonder if there must be something wrong with this process of updating this bootstrap record to the new version. Which is not error checked by the box eprom code!

  • RoyRoy Member, Super User Posts: 17,596 ✭✭✭
    edited 17 May 2018, 1:38PM

    If that engineer can explain to my satisfaction how a Maintenance Mode 4 can format the drive and yet keep your recordings, I’ll start to believe him.

    But I expect that he told you that that was what a Mode 5 did, and you missed the significance of that qualification.

    I said above it wasn’t the disc drive.

    You should not confuse various ongoing software problems other people are having with the total derangement your box is suffering from.

    The update isn’t being downloaded because your faulty hardware is preventing it.

    As I have carefully explained above, a USB key would be no use to you anyway, except under very limited circumstances that I don’t believe apply in your case.

    You can’t find a software release with Google because YouView don’t publish the releases that way. I’d be more worried if you could find something that claimed to be a YouView software release on the ‘net.

    What ‘three other screens’ does your box go through on loading?

    AAMOI, my very first YouView box suffered an irreversible hardware fault, though it remained working perfectly well for recording and watching programmes. So of course, it could go through many many screens perfectly well.

    However, it could not fetch anything from the internet; no catchup, nothing. And any attempt to do a Maintenance Mode, even an MM2 just to refresh the existing software, let alone an MM4 or an MM5, was giving the message ‘Boot Fail; Invalid Signature’.

    So please excuse me if, from personal experience, I am sceptical about the first thing you report that engineer as saying.

    And this was not just my experience; others suffered the same fate.

    And nobody offered me a USB stick; in fact Humax, though interested to get the box back and look at it, said it couldn’t even be recovered on the bench.

    Fortunately, it was under warranty, so Richer Sounds did an over the counter swap, before the box winged its way back to Humax. And the swapped-in box is working to this day, FWIW.

    Anyway, also AAMOI, did your friendly YouView engineer offer you any advice or assistance with actually getting your box working again, if such a thing is even possible, or did you just shoot the breeze while fitting some of the things you talked about into the Procrustean bed of your preconceptions?
    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
  • Max2010Max2010 Member Posts: 29
    Well I do believe you Rob but can only tell you what I have observed. As I stated to engineer I have a great deal of experience with software. All hardware platforms work with the same principles i.e. a PCB card with a boot rom on it and a drive or eprom memory.

    You keep stating my hardware is at fault but this was never in question until I operated an update through the system  update.
    My box booted correctly and I could watch channels prior to this update. The fact that my box did not record thumbnails could be easily because of lack of drive space. The lack of full recordings could be reasonably put down to same problem. The high abundance of watched recordings would favor this as being a reasonable reason. However the box should remove watched recordings, which points to a software fault.

    The fact that this update changed the whole box from a working switch on view channels to a single channel only watch and then a terminal system failure suggests it is caused by the software updating procedure not my hardware .This software update rendered the box inoperative and without the latest software.

    Are you suggesting that this update is responsible for killing my hardware? Its very unusual for anything like that to happened and most dead boards are caused by boot strap or data problems. I have looked over board and there is no evident failures through burnt out discrete components.

    In regard to the engineer I was told initially this USB port is only for a keyboard. Clearly this is untrue and evidenced by the Maintenance-MODE MM4 & MM5  both containing words " USB Recovery". I pressed the engineer on this as clearly the USB drive does support "USB Recovery".  I have asked him to supply this update on USB format he could not supply this  or would not supply this. 

    The engineer was friendly enough to open a case  which I have not had any response from so far I may call again next week and see what they suggest I was looking at the BT box until i saw it ran the same software

  • RoyRoy Member, Super User Posts: 17,596 ✭✭✭
    Cheers, Max

    I rather thought you had described issues with the box before the attempted software update, but as you say, these could just be the software glitches other people are getting,

    YouView boxes do get iffy when their drives are full or nearly full (as indeed does any computing device), and I think the delete to make space’ feature is somewhat defeated by this. (And it’s not just watched recordings, by the way. While these go first, the box will delete even old  unwatched programmes to make space for new recordings. In theory at least),

    And yes, I think the software update attempt could have killed your box, if it wasn’t already a dead man walking; you will find many reports of this in the Community. Maybe component failure through the stress of the update process, or maybe something getting the firmware into an irreversible state, not even amenable to an MM reset.

    The latter being what I think BFIS must have been.

    There certainly have been updates on USB sticks in the very distant past, but for very specialist purposes, and not on general release. Indeed, it wouldn’t surprise me to find that updates from USB sticks died with OldGen, and that NextGen doesn’t support them at all.

    On early Humax T1000s, the capacitors would tend to go out of spec. There was nothing to see (no bulging), and most of the basic measures you could make with simple test equipment - meters and the like - would still pass, and it took some quite sophisticated kit to see anything wrong.

    You have, or had, the earliest Huawei YouView box there, though. The DN372 was a better product, just as the T2nnns from Humax vastly improve on long-term reliability over the T10n0s.

    If you like the YouView experience, the modern T2nnns, or even the T4000 if you don’t try to put it through a 4K amp to a non-4K TV, should not disappoint.

    Of course, any PVR can fail - it’s chance and statistics - but the odds are much better with the more recent boxes.
    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
  • joneshjonesh Member, Super User Posts: 1,682 ✭✭✭
    edited 18 May 2018, 10:01PM
    Roy said:
    I rather thought you had described issues with the box before the attempted software update
    Max2010 said:
    This box was fine up until last week when it started locking up . I then had to turn it off several times  as it would not change channel even with new batteries. The box kept doing this until i updated software
  • Max2010Max2010 Member Posts: 29
    I telephoned Youview again today and was told that the box will work with other internet suppliers and that it is not denying me service as I am no longer a talktalk customer. I was given a number for Huawei and asked to call them . I telephoned Huawei on 0800 088 6700. They told me the box had a software fault and that Youview needed to solve the software issue!
  • RoyRoy Member, Super User Posts: 17,596 ✭✭✭
    edited 15 June 2018, 7:08AM
    Max2010 said:
    I telephoned Youview again today and was told that the box will work with other internet suppliers and that it is not denying me service as I am no longer a talktalk customer. I was given a number for Huawei and asked to call them . I telephoned Huawei on 0800 088 6700. They told me the box had a software fault and that Youview needed to solve the software issue!
    YouView will no doubt have told you that there is nothing that should stop a working YouView box from operating as a pure ‘retail’ box on other ISPs.

    Not quite the message you seem to have got, or the one you have relayed above.

    As regards denying you service, if your out-of-warranty fridge stopped being cold, would you expect to be able to ring Hotpoint and get them to fix it, because the fridge was ‘denying you service’?

    And Huawei carried out what remote diagnostics on the box to arrive at their ‘software’ conclusion, exactly?

    i am afraid, though, that until you accept that you have a box with a hardware fault, you will be stuck in a loop as thoroughly as your box is.

    You might want to ask YouView who they know of who fixes out-of-warranty YouView boxes, though; much as in my analogy above, I know Hotpoint would want to charge, but they would at least come out and look at a fridge less than five years old....
    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
Sign In or Register to comment.