Ultra box not switching on, no power at all

usrobotusrobot Member Posts: 2
no power , have tried resetting the swich on the back to no avail


  • RoyRoy Member, Super User Posts: 15,905 ✭✭✭
    Hi @usrobot and welcome to the Community!

    OK, a DTR-T4000....

    Start at the wall, and trace the path to and through the power brick.

    Is the wall outlet switched? If so, is it switched on? Is the power brick plugged in to it?

    Or is it maybe on a multiplug extension? Is that all plugged in, and, if switched, switched on?

    If everything is seemingly OK here, hold the power brick in your hand. Can you feel the vibration, or is it lifeless? If you have a battery meter, can you check the brick’s output voltage is what it should be?

    If the brick seems dead, double-check its power-in by plugging something else into the power socket it is using, e.g. a lamp, to be sure that is working.

    And check the fuse in the 13-amp plug on the brick.

    If you have a dead brick after all this, ask BT for a new one.

    But if your brick seems to be OK, but the T4000 itself is lifeless, get BT to come and look at it. Hopefully, it will be just an internal fuse that has blown and needs replacing, which they can do for you, or maybe it is more fundamental, and you will need a new box.

    But either way, you don’t want to open the box yourself and invalidate the warranty, and BT will get you motoring again. 

    Good luck!
    These tests for COVID-19 get right up my nose.
  • usrobotusrobot Member Posts: 2
    Thanks Roy, but I have already tried those things
  • SarahSarah Administrator Posts: 1,576 admin
    Hi @usrobot
    Have you tried giving BT a ring about this? I think they'll be able to assist you further to get your box going again or provide a replacement if you're still with them. 
  • RoyRoy Member, Super User Posts: 15,905 ✭✭✭
    usrobot said:
    Thanks Roy, but I have already tried those things
    Cheers, @usrobot

    Sorry to go back right to basics, but as you didn’t list anything you had tried, I wasn’t sure what was what.

    So, which is it that has failed, the power brick, or the box itself?
    These tests for COVID-19 get right up my nose.
Sign In or Register to comment.