YOUVIEW losing HD channels when updated

I every time the youview box updates I lose the HD channels and have to rescan

Comments

  • John LJohn L Posts: 322Member
    Hi MillieMoo,
    Welcome to the forum. You are not alone. Lots of problems with channels getting lost.
    Which Youview model do you have/which is your local transmitter? 

    The first check I would do is unplug aerial from youview & replug lead into tv.

    So then do a retune & check that your tv's own built in tuner can receive all channels inc HD ones first. Also good idea is to use the signal strength meter (can be found via your tv's menu settings & check signal strength/quality). You can also do this on the Youview box as well when testing. Ideally should be a high figure. Do you also use a aerial booster amp? :highly recommended in most cases.  This may boost signal & help you.

    One top tip when retuning, especially when you have problems, is to UNPLUG aerial, retune to get NO channels (clears channel memory) then REPLUG lead & retune again. 

    Hopefully this may resolve issue, but if you need more help please ask.
    Please let the forum know how you get on. John L
  • SarahSarah Posts: 1,361Administrator admin
    Hi @MillieMoo
    Welcome to the forum :) 
    Can you please let us know which transmitter you are tuned to? You can find out by going to the Freeview website, scrolling down a little bit and enter your postcode and door number. 
    Thanks,
    Sarah
Sign In or Register to comment.