Help to connect a new router to my youview box

Hi I've just had a new router sent to me which is all connected up but it won't talk to my box/ TP Link. I've tried all the suggestions under the support code - restarted router, youview, TP Link disconnected and reconnected and nothing works. I tried to do the manual connection but not sure where I can find the IP details and I don't think I did this before when I first set up the internet with my youview box. Any suggestions gratefully received. I've had a weak line for ages which has just been fixed and I've missed being able to watch I player etc.  thank you in advance for any advice on this. 


  • RoyRoy Member, Super User Posts: 16,377 ✭✭✭
    @“Alex Collett”

    What’s the TP-Link? Is it a nanorouter, used on the YouView box instead of an Ethernet cable? If so, it needs to be reconfigured to use the SSID and password of your new router.

    Or is it a pair of PLAs? In which case, turn off all four devices, and then power up each in turn, starting at the router, then the PLA at that end, then the PLA at the YouView end, and then the YouView box itself.

    But if it’s neither, or the advice doesn’t work, please come back with more details.
    Back to my usual level of bafflement, then...
  • Alex CollettAlex Collett Member Posts: 10
    Hi Roy - thanks for replying.  its the former yes. used instead of an ethernet cable.   I can see the SSID and password on the TP Link. Where do I find the SSID and password of my new router? and do I reconfigure on my computer to do this? where do I access? is that the hub manager?

  • Alex CollettAlex Collett Member Posts: 10
    Hi Roy- Alex here again! I know where the wireless network and password is for my new router. I've also done the reset on my TP and then pressed WPS on the new router.  Still not connected. The IP address in my hub manager is different from the one on my new router (this is EE). Should they be the same? All the troubleshooting links/you tube videos I look at tell me to do the reset on the TP (until green light is flashing) then it takes them to a TP link screen to then add the new wireless network and password - through the wizard basically. but I can't get this screen up? only the EE Hub Manager. Am very confused now. 
  • RoyRoy Member, Super User Posts: 16,377 ✭✭✭
    Hi Alex

    The EE site suggests the Hub Manager is at

    As far as I know, the Hub Manager *is* the router so what do you think the router IP address is? 

    But there is no reason why the router can’t support two IP addresses, one to manage it, and one to connect to. But I don’t know.

    I have a very useful app called Fing, which is free, and available for iOS or Android, which you can use on a tablet or phone, and will discover all the IP addresses in use on your WiFi network, and what devices are at these addresses.

    I’ve connected a YouView box over a TP-Link nanorouter in the past, and IIRC, it supported WPS; though I actually configured it by finding its IP address as revealed by Fing on my iPad, and then going to it in a browser on my laptop, and putting the settings in there.

    I got a manual with the TP-Link that I used, and you should have one, or be able to find it on the web. I can’t do these things off videos, as they either take it glacially slowly, or rush through the important bits (usually both in the same video) so I prefer to go through the manual at my own pace.

    But I think we may have established here that your problem, or at least your initial one, is getting the TP-Link talking to the EE router, and maybe you will get some good help with this on the EE forum, as at or around:-

    Once you have that sussed, the YouView connection may be straightforward; or you may have further issues you can bring back here for us to help with.

    Good hunting!
    Back to my usual level of bafflement, then...
  • Alex CollettAlex Collett Member Posts: 10
    Hi Roy

    Thanks so much for your detailed reply. I actually spoke to EE at length about this and they are baffled as to why it is not talking to my new router (and were very sympathetic actually!). BUT they suggested as I've just gone from a standard broadband line to a fibre optic (which is still settling in as put in only on 3 Jan) that the TP Link might be too old to be compatible?  I can see the TP Link on my network but when I sign in to it, it then defaults as my only router and it doesn't then connect to the internet. So I had to go back to my new EE one (which I want that to be the main WiFi anyway).  I have emailed TP Support and put the question to their community as well. not heard back yet. I just want to know that IF the answer is to buy a new TP that it will definitely work and its not something else I need to do. But I see what EE are suggesting and in fact when they went to look for WR702N they could not find it. I also went on TP to see if I could download anything new as an update for my TP but there wasn't anything.

    One question (and yes I have kept the manual for the TP and also the disc). the manual doesn't say any instructions about a new router but is it worth me running the disc again? I suppose there is no harm in it? I will of course also try Fing on my tablet and see what happens there.  Your thoughts on whether the new fibre optic line might be the issue would be appreciated.   Many thanks indeed for taking the time to help me. Really grateful.

  • RoyRoy Member, Super User Posts: 16,377 ✭✭✭
    @“Alex Collett”

    EE should learn to use Google  :p

    I’ll go and poke in my bits box for my TP-Link, see which one it was, but it was working fine on 150Mb FTTR (fibre to the router), the like of which BT Openreach can only gaze at in dismay, to link my T1000 to Movistar internet in Spain.

    If your TP-Link is opening as a router, I’d say it has lost its configuration, as it should be opening as a relay, or a bridge, or something similar (I forget which, for the moment), a mode you need to switch it into before anything else.

    I’ll see if I can find mine, and the manual for it, and pop back on later on.

    Back to my usual level of bafflement, then...
  • RoyRoy Member, Super User Posts: 16,377 ✭✭✭
    edited 5 January 2020, 4:50PM
    Can’t lay my hands on it at the moment, but I have found that it’s client mode you want, as in:-

    There seem to be earlier firmware versions of this nanorouter, which may be where your difficulty lies; check your firmware version before applying the advice. 

    Maybe even apply the firmware upgrade if you haven’t already, though doing that might be how the device lost its previous Client Mode status.

    I’m pretty sure my nanorouter was even older than yours, as it had aerials.
    Back to my usual level of bafflement, then...
  • Alex CollettAlex Collett Member Posts: 10
    Hi Roy

    Thanks so much for checking. Funnily enough after I typed my message to you. the TP Support team emailed me! They sent me a link to access Repeater Mode rather than Client Mode? but all the other instructions are the same. However both instructions state as Step 1:

    Connect the computer to the TL-WR702N with an Ethernet cable. Open the web browser and type the IP address  into the address bar and then Press Enter.

    My computer is connected in my hall on a desk and no where near the nanorouter.  My new EE router is close though and the cable would reach? but then I won't get what I need in the web browser .....or will I? My tablet doesn't have a ethernet cable port unfortunately.  So annoying as I can't remember how I did it before, my neighbour helped but can't remember what process we made to get it. If this is the only way to do it then I will move my whole computer into the lounge by the TP in order to access it.  But is it not possible without the ethernet cable? TP did understand I am accessing it wirelessly but they didn't say anything else bar to use 'repeater mode'.  

    What do you suggest? Can I just link my new router to it temporarily or do I need to move my whole computer and link via ethernet to the TP?

    So sorry to bother you again and really appreciate your assistance.  We're getting there I feel.

    Thanks. Alex  

  • RoyRoy Member, Super User Posts: 16,377 ✭✭✭
    edited 5 January 2020, 9:09PM
    I think Repeater Mode is wrong. Maybe whoever advised you to use this didn’t understand what you were trying to do?

    But don’t take my word for it, look up both Modes on the TP-Link site, first Repeater Mode:-
    then Client Mode:-
    and compare the two diagrams. 
    Which do you think is what we are trying to achieve here?
    And the nano router is incredibly portable. Don’t get hung up on having to leave it connected to the YouView box while trying to configure it; in fact you can’t, as the Ethernet cable needs to go between it and the computer for the configuration step.

    So just take the nano router, and the Ethernet cable that connected it, and the power cable (USB or mains adapter?) off the YouView box, take it out to where the computer is, connect the Ethernet cable between computer and nanorouter, connect the power to the nano router, switch it on, and configure it. To Client Mode, I hope. (Repeater Mode would connect it to the EE router, but then it wouldn’t do the job the YouView box requires).
    When you get it working, it will be in touch with the router by WiFi. Then just move it back into connection with the YouView box over the Ethernet cable, and see how things go, if it lets the YouView box connect now.
    Back to my usual level of bafflement, then...
  • joneshjonesh Member, Super User Posts: 1,517 ✭✭✭
    edited 5 January 2020, 9:18PM
    My new EE router is close though and the cable would reach?
    Just a thought @Alex Collett . . .
    If your new EE router is close to the nano router, which is connected to your Youview box by a cable, isn't it possible to connect the EE router directly to the Youview box using a cable?
  • Alex CollettAlex Collett Member Posts: 10
    @jonesh - yes I wish I could do that but the EE router is at the door of my lounge (so it can talk to my computer down the hall away from walls) and my nano is in a cupboard across the lounge on the other side. Sadly it won't work like that but thanks for the suggestion-  I wish it did! :( 
  • Alex CollettAlex Collett Member Posts: 10
    @Roy - yes I see exactly what you mean. Client Mode is what I want. Thanks so much.
    I will try the logistics of taking the nano and youview box to the computer and go from there. I'll let you know how I get on! Fingers crossed!  Thanks again! 
  • RoyRoy Member, Super User Posts: 16,377 ✭✭✭
    A small thought - thinking more about it, I reckon Repeater Mode would actually work, as long as the TP-Link still monitors the Ethernet link in that Mode.

    But it would also have the TP-Link broadcasting the router SSID, as if it was the router; and so many WiFi devices that are actually in range of the EE router might decide to connect via the TP-Link instead of directly, which would likely slow down their WiFi connections.

    An insidious (inSSIDious?) drawback of Repeater Mode, that Client Mode avoids.
    Back to my usual level of bafflement, then...
Sign In or Register to comment.