SPulSPul Member Posts: 2
I believe that this has been a long standing problem and its beginning to anoy me. This fault prevents using catch up TV for Channel 4 on a Sony TV. Please can you provide a solution?


  • RoyRoy Member, Super User Posts: 16,549 ✭✭✭
    Have you worked through the steps on this page?

    The next step, inexplicably not given there, is to Factory Reset the TV, Sony’s panacea for all ills, whether it works or not.
    Supporting YouView on Sony TVs is like nailing jelly to a herd of cats
  • SPulSPul Member Posts: 2
    Thanks for the suggestion Roy. I've tried it all, including factory reset and still the same error.
  • Joey_Diaz52Joey_Diaz52 Member Posts: 11
    Hi, you may want to give the step below my next door neighbour had this issue months ago and this fixed it for him:
    1. Press Home
    2. Scroll down to Settings
    3. In the TV section scroll right to Apps
    4. Go to System Apps
    5. Hold the right button to scroll all the way to the end and Select YVServiceHost APK
    6. Select Clear Cache and press OK
    7. Then Select Clear Data and press OK
  • TaragindiTaragindi Member Posts: 1
    I have been having the same issue and although I followed these steps it hasn't resolved it.
    Has anyone else been able to sort this out?
    Would appreciate anything on offer..!
Sign In or Register to comment.