Sony A8 ITV app can't watch ITV channel content

JamieDJamieD Member Posts: 2
I have a Sony A8 OLED with the latest software update as of 22nd Jan 2021. When using the built in ITV hub app I am unable to view any content from the ITV channel.

I’ve entered my postcode and it’s recognised but when I am on the Home Screen there are no itv programs displayed. When I goto the Channels section I get a message on the ITV screen saying the content is not available as we haven’t been able to locate your region.

It then has a link to set my location. When clicking this I am taken the location input screen which says my region has been set to ITV.

I have tried re-entering the postcode but this makes no difference, I have also tried resetting the app and logging in again and still have the same problem.

I have several other smart TVs and Apple TVs in the house, all of which are setup using the same account and postcode and don’t have any issues.

The postcode I am entering is “PL” at which point it says it recognises the postcode and I can continue. I have also tried entering my full postcode which makes no difference.

I have also tried following the data and cache reset procedure detailed here for the "Live TV & Catchup" app https://support.youview.com/youview-on-sony/on-demand-players-apps/on-demand-player-not-working/ in Step 1.

Could I get some help with being able to watch ITV content on this TV please?

Comments

  • RoyRoy Member, Super User Posts: 16,549 ✭✭✭
    @JamieD

    Are you trying to run your TV without a terrestrial aerial connected?

    Although you should be able to, it looks as though you can’t, at the moment, an issue which Sony and YouView are currently investigating.

    If you can easily connect a terrestrial aerial, do that and run the tuning, and then try for the itv Hub again.

    If this isn’t feasible for you, and you don’t want to wait for the fix, then a £30 Amazon FireStick will let you do what your £1000+ TV can’t.
    Supporting YouView on Sony TVs is like nailing jelly to a herd of cats
  • JamieDJamieD Member Posts: 2
    @roy Thanks, that was the problem, I had to buy a 25m TV cable so I could plug it in. All working now.
Sign In or Register to comment.