iOS app not working.

SavenSaven Member Posts: 63
edited 6 December 2021, 6:33PM in Community
iOS app not working for me (not a bt tv subscriber) at the moment. Requires BT sign in. Is this something new?
Or at least it has changed considerably. 


  • scotty16scotty16 Member Posts: 11
    In the "App Astore", after I search for "BT TV", I am offered an update to the app. Will this sort the problem ?
  • SavenSaven Member Posts: 63
    Thanks for your reply. I have the latest update from 3 Dec and I think that may have broken the app.
  • scotty16scotty16 Member Posts: 11
    Couldn't find date of my app but at the bottom of the "Settings" page it says "App Version 4.4.3". How does that compare ?
  • SavenSaven Member Posts: 63
    I’ve just tried an iPad that hasn’t been updated and the BT App is the same so the change is at the BT end, not the device. BT made the app record facilities available to non BT TV subscribers a year or two back. Maybe they’ve reversed that.
    I can set recordings from the guide but everything else has to be done on the box. I don’t think series record is working.
  • scotty16scotty16 Member Posts: 11
    They have absolutely no respect for us users it seems. I'd contact BT direct but I know what the answer will be.
  • SavenSaven Member Posts: 63
    scotty16 said:
    Couldn't find date of my app but at the bottom of the "Settings" page it says "App Version 4.4.3". How does that compare ?
    Mine shows 4.4.4. Is yours operating normally? Also, are you a BT TV subscriber?
  • SavenSaven Member Posts: 63
    We’ll I’ll be …….!

    Just went to the app and it’s working back to normal.

    Thanks all for your help. 
  • scotty16scotty16 Member Posts: 11
    Mine is same as yours was, asking me to sign in which I can't because I'm not with BT (or TalkTalk for that matter, I'm with Sky). Tried again, no change, so tried forcing a re-boot - still no change. Will update...…. now on 4.4.4...…. still asking me to sign in so no change for me. I'll see what tomorrow brings. For now back to disturbing the family while setting recordings.
  • SavenSaven Member Posts: 63
    At the moment it’s back to normal on the iPhone and back to weird on the iPad. Obviously happening at the bt end.
  • zulu17zulu17 Member, Super User Posts: 1,122 ✭✭✭
    edited 7 December 2021, 12:14AM
    From looking at BT community. 
    There was a server upgrade this morning and it appears to have booted out non subscribers.  
    So the right people in BT are aware and were looking to resolve ASAP.

    update . a recent post indicates that it should now be resolved.
  • RoyRoy Member, Super User Posts: 17,527 ✭✭✭
    @zulu17 @saven @scotty16

    I’ve just tried this BT app on my iPad, and it’s working fine at this time of posting, doing everything I’ve tried that I’ve been able to do before without a BT TV subscription.

    So it does indeed look like BT fixed it.

    iPadOS 15.1, BT app 4.4.4, for what it’s worth.
    ‘Have nothing in your houses that you do not know to be useful, or believe to be beautiful’ Wm Morris
  • DarrenDarren Member, Super User Posts: 639 ✭✭
    edited 7 December 2021, 8:24AM
    The BT TV app works fine on my iPad Mini 6 with 15.1 with no problems.
    I dont have 15.1 on my iPhone XR just yet. Just ios 15 and the BT TV works fine on that.
  • SavenSaven Member Posts: 63
    All seems to be back to normal now. Thanks everyone. 
  • scotty16scotty16 Member Posts: 11
    All back to normal for me now - thank you BT technicians.
  • SavenSaven Member Posts: 63
    As of now it’s not working again on any iOS device
  • SavenSaven Member Posts: 63
    Now back. Comes and goes. They’re obviously working on it. Many thanks to them.
Sign In or Register to comment.